aboutsummaryrefslogtreecommitdiffstats
path: root/macros/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1999-02-04 21:04:51 +0800
committerMartin Baulig <martin@src.gnome.org>1999-02-04 21:04:51 +0800
commit23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2 (patch)
treea57570cbafe5a325ca6eaa4a00271326ea2f572d /macros/Makefile.am
parent9760a8f9712378bbd32b8cd502bf4ebf53104c51 (diff)
downloadgsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar.gz
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar.bz2
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar.lz
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar.xz
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.tar.zst
gsoc2013-evolution-23e6445f8ba8f0173ac2c0f5e65985f0ffa9e2c2.zip
New automake conditional that's always false.
1999-02-04 Martin Baulig <martin@home-of-linux.org> * aclocal-include.m4 (INSIDE_GNOME_COMMON): New automake conditional that's always false. * gnome-common.m4: New file. This defines a `GNOME_COMMON_INIT' macro that should be used in all GNOME Applications outside the CVS tree. * Makefile.am: If we are `INSIDE_GNOME_COMMON', install all $(MACROS), autogen.sh, gnome-common.m4 and a newly created gnome-macros.dep in `$(datadir)/aclocal/gnome'. svn path=/trunk/; revision=640
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
index c354713040..2922a907ac 100644
--- a/macros/Makefile.am
+++ b/macros/Makefile.am
@@ -22,8 +22,18 @@ MACROS= \
linger.m4 \
need-declaration.m4
-EXTRA_DIST=$(MACROS) autogen.sh
+EXTRA_DIST=$(MACROS) gnome-common.m4 autogen.sh
MAINTAINERCLEANFILES=macros.dep
@MAINT@macros.dep: Makefile.am
@MAINT@ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=macros/%)' > $@
+
+if INSIDE_GNOME_COMMON
+gnome_aclocaldir = $(datadir)/aclocal/gnome
+
+gnome-macros.dep: Makefile.am
+ @echo '$$(top_srcdir)/aclocal.m4: $(MACROS:%=$(gnome_aclocaldir)/%)' > $@
+
+gnome_aclocal_DATA = $(MACROS) gnome-macros.dep gnome-common.m4 autogen.sh
+
+endif