aboutsummaryrefslogtreecommitdiffstats
path: root/macros/Makefile.am
diff options
context:
space:
mode:
authorRaja R Harinath <harinath@src.gnome.org>1998-02-14 02:01:43 +0800
committerRaja R Harinath <harinath@src.gnome.org>1998-02-14 02:01:43 +0800
commit8324e4c38d205f89d06fc912a4b19c84e6762539 (patch)
tree19b184cdd6cfa5ef0f110b0612ab3d57182c9b77 /macros/Makefile.am
parent01ce31066fcd790c960d7e49ce9661127ce7174a (diff)
downloadgsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar.gz
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar.bz2
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar.lz
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar.xz
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.tar.zst
gsoc2013-evolution-8324e4c38d205f89d06fc912a4b19c84e6762539.zip
New maintainer rule for handling automatic rebuilding of aclocal.m4 if any
* Makefile.am (macros.dep): New maintainer rule for handling automatic rebuilding of aclocal.m4 if any of the macros change. (MACROS): New variable. List of all `m4' macros in this directory. - Hari svn path=/trunk/; revision=20
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
index d2969a8305..8dabbbcc12 100644
--- a/macros/Makefile.am
+++ b/macros/Makefile.am
@@ -1,2 +1,9 @@
-EXTRA_DIST=aclocal-include.m4 \
- gnome.m4 gnome-x-checks.m4
+## Please update this variable if any new macros are created
+MACROS= aclocal-include.m4 gnome-guile-checks.m4 \
+ gnome-objc-checks.m4 gnome-x-checks.m4 gnome.m4
+
+EXTRA_DIST=$(MACROS)
+MAINTAINERCLEANFILES=macros.dep
+
+@MAINT@macros.dep: Makefile.am
+@MAINT@ @echo "$$(top_srcdir)/aclocal.m4: $(MACROS:%=macros/%)" > $@