aboutsummaryrefslogtreecommitdiffstats
path: root/libversit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Rittau <srittau@src.gnome.org>2002-03-12 08:41:53 +0800
committerSebastian Rittau <srittau@src.gnome.org>2002-03-12 08:41:53 +0800
commit4a54ffc858eaa2693044a981372644321c7316c5 (patch)
treef0be65e2f36e9957964ab9e5d6662f8dff181ce5 /libversit/Makefile.am
parent4a3b1a551d58baa452006df9e927773209ce56f1 (diff)
downloadgsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar.gz
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar.bz2
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar.lz
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar.xz
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.tar.zst
gsoc2013-evolution-4a54ffc858eaa2693044a981372644321c7316c5.zip
Christian: Fix linker errors on SGI IRIX 6.5 by not using libtool for
* libversit/Makefile.am: * gncal/Makefile.am: * gnomecard/Makefile.am: Christian: Fix linker errors on SGI IRIX 6.5 by not using libtool for libversit.a. (Bugzilla #61031) -rpath removal and some small cleanups by me. * gncal/corba-cal-factory.c: (init_corba_server, unregister_calendar_services): Christian: Fix startup crashes. * gncal/calobj.c: (ical_object_to_vobject): Christian: Don't save dtend if it's 0 (i.e. the epoch 1970-01-01 00:00). Partly addresses Bugzilla #6058. * gncal/calendar.c: (calendar_open): Store errno privately so that the displayed error message is correct. * gncal/gncal-week-view.c: (gncal_week_view_set): Put %W time format string in week_end part, since otherwise we get problems when the week start is set to Sunday. Also use %V instead of %W to get the ISO week number, instead of the C week number. This makes the week number consistent with the one from GtkCalendar. * libversit/vcc.y: Christian: Fix a problem with locale-dependent string comparisons. (Bugzilla #64801) svn path=/trunk/; revision=16114
Diffstat (limited to 'libversit/Makefile.am')
-rw-r--r--libversit/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/libversit/Makefile.am b/libversit/Makefile.am
index 5d42636c1c..63c677ccae 100644
--- a/libversit/Makefile.am
+++ b/libversit/Makefile.am
@@ -1,7 +1,8 @@
+# Makefile for libversit.a
-noinst_LTLIBRARIES = libversit.la
+# $Id: Makefile.am,v 1.8 2002/03/12 00:41:53 srittau Exp $
-libversit_la_SOURCES = \
+VERSIT_SRC = \
vcc.y \
vcc.h \
vobject.c \
@@ -10,6 +11,12 @@ libversit_la_SOURCES = \
vcaltmp.c \
vcaltmp.h
+noinst_LIBRARIES = libversit.a
+noinst_LTLIBRARIES = libversit_lt.la
+
+libversit_a_SOURCES = $(VERSIT_SRC)
+libversit_lt_la_SOURCES = $(VERSIT_SRC)
+
EXTRA_DIST = README.TXT vcaltest.c vctest.c
YFLAGS=-pversit_