aboutsummaryrefslogtreecommitdiffstats
path: root/libical/src/libicalvcal/Makefile.am
diff options
context:
space:
mode:
authorDamon Chaplin <damon@ximian.com>2002-02-07 07:16:12 +0800
committerDamon Chaplin <damon@src.gnome.org>2002-02-07 07:16:12 +0800
commitd64e7cf12f73a73a0c5b99806fd695d428bea72f (patch)
treee2c8ce675a8ff8c7b8683996f12281ab973071c9 /libical/src/libicalvcal/Makefile.am
parent411fd545df9ba41609b00e67e96369f493fe0610 (diff)
downloadgsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar.gz
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar.bz2
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar.lz
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar.xz
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.tar.zst
gsoc2013-evolution-d64e7cf12f73a73a0c5b99806fd695d428bea72f.zip
major changes to support RRULE/EXRULE, VALARMS and several other
2002-02-06 Damon Chaplin <damon@ximian.com> * src/libicalvcal/icalvcal.c: major changes to support RRULE/EXRULE, VALARMS and several other properties. * src/libicalvcal/icalvcal.h (icalvcal_convert_with_defaults): new function to pass defaults for a few values into the importer. These are used when the vCalendar file doesn't provide the property but it is required in iCalendar. * src/libicalvcal/vcc.y: support multi-valued properties, by appending new ones and separating by ';'. This was pinched from our changes to evolution/libversit/vcc.y. * src/libicalvcal/Makefile.am: renamed library to libicalvcal-evolution Don't install the headers. * design-data/parameters.csv: added new error for error's parsing vCalendar properties. svn path=/trunk/; revision=15582
Diffstat (limited to 'libical/src/libicalvcal/Makefile.am')
-rw-r--r--libical/src/libicalvcal/Makefile.am25
1 files changed, 15 insertions, 10 deletions
diff --git a/libical/src/libicalvcal/Makefile.am b/libical/src/libicalvcal/Makefile.am
index c409347d14..e8e8310941 100644
--- a/libical/src/libicalvcal/Makefile.am
+++ b/libical/src/libicalvcal/Makefile.am
@@ -1,4 +1,4 @@
-lib_LTLIBRARIES = libicalvcal.la
+lib_LTLIBRARIES = libicalvcal-evolution.la
INCLUDES = \
-I$(top_builddir) \
@@ -6,22 +6,27 @@ INCLUDES = \
-I$(top_builddir)/src/libical \
-I$(top_srcdir)/src/libicalss
-libicalvcal_la_LDFLAGS = -version-info 0:0:0
+libicalvcal_evolution_la_LDFLAGS = -version-info 0:0:0
-libicalvcal_la_SOURCES = \
+libicalvcal_evolution_la_SOURCES = \
+ icalvcal.h \
icalvcal.c \
+ port.h \
+ vcc.h \
vcc.y \
+ vobject.h \
vobject.c \
+ vcaltmp.h \
vcaltmp.c
-libicalvcalincludedir = $(includedir)/libicalvcal
+#libicalvcalincludedir = $(includedir)/evolution/libicalvcal
-libicalvcalinclude_HEADERS = \
- icalvcal.h \
- port.h \
- vcc.h \
- vobject.h \
- vcaltmp.h
+#libicalvcalinclude_HEADERS = \
+# icalvcal.h \
+# port.h \
+# vcc.h \
+# vobject.h \
+# vcaltmp.h
EXTRA_DIST = \
README.TXT \