aboutsummaryrefslogtreecommitdiffstats
path: root/libical/configure.in
diff options
context:
space:
mode:
authorJP Rosevear <jpr@src.gnome.org>2001-01-24 04:22:40 +0800
committerJP Rosevear <jpr@src.gnome.org>2001-01-24 04:22:40 +0800
commit4028f454b6c274fa093056180af8d11e5c7bfd1e (patch)
tree0152cebbfed39e61ca4fb959cbaa49b5a8b3f528 /libical/configure.in
parentbf4a1512b2fc7b83ce723ecafbb02947e577e7d8 (diff)
downloadgsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar.gz
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar.bz2
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar.lz
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar.xz
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.tar.zst
gsoc2013-evolution-4028f454b6c274fa093056180af8d11e5c7bfd1e.zip
Import clean up
svn path=/trunk/; revision=7751
Diffstat (limited to 'libical/configure.in')
-rw-r--r--libical/configure.in50
1 files changed, 28 insertions, 22 deletions
diff --git a/libical/configure.in b/libical/configure.in
index 3ce77c6ca5..83f3e1ed22 100644
--- a/libical/configure.in
+++ b/libical/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(src/libical/icaltypes.h)
+AC_INIT(src/libical/ical.h)
+AM_INIT_AUTOMAKE(libical,0.22a)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(libical,0.21helix1)
dnl Initialize maintainer mode
AM_MAINTAINER_MODE
@@ -17,9 +17,11 @@ dnl Initialize libtool
AM_PROG_LIBTOOL
AC_SUBST(AR)
+
AC_CHECK_PROGS(AR, ar aal, ar)
+AC_CHECK_PROGS(PERL, perl5 perl)
-dnl AC_DEFINE(ICAL_ERRORS_ARE_FATAL,1)
+AC_DEFINE(ICAL_ERRORS_ARE_FATAL,1)
AC_DEFINE(ICAL_SAFESAVES,1)
AC_DEFINE(ICAL_UNIX_NEWLINE,1)
@@ -37,27 +39,30 @@ AC_TYPE_SIZE_T
AC_STRUCT_TM
AC_CACHE_CHECK(for timezone variable, ac_cv_var_timezone,
- AC_TRY_COMPILE([
- #include <time.h>
- ], [
- timezone = 1;
- ], ac_cv_var_timezone=yes, ac_cv_var_timezone=no))
+ AC_TRY_COMPILE([
+#include <time.h>
+ ], [
+ timezone = 1;
+ ], ac_cv_var_timezone=yes, ac_cv_var_timezone=no))
if test $ac_cv_var_timezone = yes; then
- AC_DEFINE(HAVE_TIMEZONE)
+ AC_DEFINE(HAVE_TIMEZONE)
else
- AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
- AC_TRY_COMPILE([
- #include <time.h>
- ], [
- struct tm tm;
- tm.tm_gmtoff = 1;
- ], ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no))
- if test $ac_cv_struct_tm_gmtoff = yes; then
- AC_DEFINE(HAVE_TM_GMTOFF)
- else
- AC_ERROR(unable to find a way to determine timezone)
- fi
-fi
+ AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
+ AC_TRY_COMPILE([
+#include <time.h>
+ ], [
+ struct tm tm;
+ tm.tm_gmtoff = 1;
+ ], ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no
+))
+ if test $ac_cv_struct_tm_gmtoff = yes; then
+ AC_DEFINE(HAVE_TM_GMTOFF)
+ else
+ AC_ERROR(unable to find a way to determine timezone)
+ fi
+fi
+
+
dnl Checks for library functions.
AC_CHECK_FUNCS(strdup)
@@ -76,3 +81,4 @@ src/libical/icalversion.h
src/libicalvcal/Makefile
test-data/Makefile
])
+