aboutsummaryrefslogtreecommitdiffstats
path: root/libical/configure.in
diff options
context:
space:
mode:
authorHans Petter Jansson <hpj@ximian.com>2003-09-24 10:06:52 +0800
committerHans Petter <hansp@src.gnome.org>2003-09-24 10:06:52 +0800
commit9cd7b8f8ba994fc509c52028aed2d0b14bce175a (patch)
treece7a55922992f74549f4d7e4cba3b945edc65c09 /libical/configure.in
parent1b5c1357dcbf4cfcd450c33d76c51c2e14252cf8 (diff)
downloadgsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar.gz
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar.bz2
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar.lz
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar.xz
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.tar.zst
gsoc2013-evolution-9cd7b8f8ba994fc509c52028aed2d0b14bce175a.zip
Remove flex check. Set ICAL_ERRORS_ARE_FATAL to 0.
2003-09-23 Hans Petter Jansson <hpj@ximian.com> * configure.in: Remove flex check. Set ICAL_ERRORS_ARE_FATAL to 0. * src/libicalss/icalgauge.c (icalgauge_new_from_sql): Don't use globals struct. Remove calls to sslex_init(), _extra(), ss_scan_string(). Use a global pointer icalss_yy_gauge to hold context. Call ssparse() with no arguments. * src/libicalss/icalsslexer.l: Remove options reentrant and bison-bridge. Rename variables, change function invocations to comply with flex 2.5.4. (icalss_input): Add function to read input. * src/libicalss/icalssyacc.y (yyextra): Remove. (select_list) (from_list) (where_clause) (where_list): yyextra -> icalss_yy_gauge * src/libicalss/icalsslexer.c: * src/libicalss/icalssyacc.c: * src/libicalss/icalssyacc.h: Add generated files back to repository. They don't belong there, but that's not my problem. svn path=/trunk/; revision=22683
Diffstat (limited to 'libical/configure.in')
-rw-r--r--libical/configure.in16
1 files changed, 1 insertions, 15 deletions
diff --git a/libical/configure.in b/libical/configure.in
index 59c3fece7d..20edeed3e6 100644
--- a/libical/configure.in
+++ b/libical/configure.in
@@ -98,20 +98,6 @@ dnl *** Yacc/Bison support
if test "x$USE_MAINTAINER_MODE" == xyes; then
DEV="yes"
AC_MSG_RESULT([Setting up for development: -Wall, flex, bison])
-
- AC_MSG_CHECKING(for flex >= 2.5.31)
- flex_major=$(flex --version | sed 's/flex \(version\)\? \?'// | cut -d '.' -f 1 2>/dev/null)
- flex_minor=$(flex --version | sed 's/flex \(version\)\? \?'// | cut -d '.' -f 2 2>/dev/null)
- flex_revision=$(flex --version | sed 's/flex \(version\)\? \?'// | cut -d '.' -f 3 2>/dev/null)
-
- if (( $flex_major < 2 || \
- ($flex_major == 2 && $flex_minor < 5) || \
- ($flex_major == 2 && $flex_minor == 5 && $flex_revision < 31) )); then
- AC_MSG_RESULT($flex_major.$flex_minor.$flex_revision - no)
- AC_MSG_ERROR([You need flex >= 2.5.31 to build libical for development - http://lex.sourceforge.net/])
- else
- AC_MSG_RESULT($flex_major.$flex_minor.$flex_revision - yes)
- fi
fi
AM_CONDITIONAL(DEV, test x$DEV = xyes)
@@ -167,7 +153,7 @@ AM_CONDITIONAL(WITH_CAP, test x$WITH_CAP = xyes)
dnl **************************************************
dnl test/regression.c (and maybe others) needs this defined
dnl **************************************************
-AC_DEFINE(ICAL_ERRORS_ARE_FATAL,1,[Define to make icalerror_* calls abort instead of internally signalling an error])
+AC_DEFINE(ICAL_ERRORS_ARE_FATAL,0,[Define to make icalerror_* calls abort instead of internally signalling an error])
AC_DEFINE(NO_WARN_DEPRECATED,1,[Define to 1 if you DO NOT WANT to see deprecated messages])
AC_DEFINE(NO_WARN_ICAL_MALFORMEDDATA_ERROR_HACK,1,[Define to 1 if you DO NO WANT to see the warning messages related to ICAL_MALFORMEDDATA_ERROR and parsing .ics zoneinfo files])