aboutsummaryrefslogtreecommitdiffstats
path: root/libical/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-07 02:13:57 +0800
committerDan Winship <danw@src.gnome.org>2003-02-07 02:13:57 +0800
commit3a315cf4f36f13f791b6b728531ba4704c13b186 (patch)
tree9374efc1f74f0873e441ddcbb064f4841be43c45 /libical/configure.in
parentdb141482ef299e20092600972a6f328cb3eac878 (diff)
downloadgsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar.gz
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar.bz2
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar.lz
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar.xz
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.tar.zst
gsoc2013-evolution-3a315cf4f36f13f791b6b728531ba4704c13b186.zip
AC_SUBST privlibdir, privincludedir, privdatadir (sent from ../configure).
* configure.in: AC_SUBST privlibdir, privincludedir, privdatadir (sent from ../configure). Add descriptions to AC_DEFINEs. Don't bother checking for python since we don't build it anyway. * acconfig.h: Gone * src/libical/Makefile.am: install library in privlibdir and headers under privincludedir. Look for zone files in privdatadir * src/libicalvcal/Makefile.am: install in privlibdir * zoneinfo/Makefile.am (zoneinfodatadir): define in terms of privdatadir (install-data-local): update svn path=/trunk/; revision=19823
Diffstat (limited to 'libical/configure.in')
-rw-r--r--libical/configure.in15
1 files changed, 10 insertions, 5 deletions
diff --git a/libical/configure.in b/libical/configure.in
index 71b5183831..02275e8d74 100644
--- a/libical/configure.in
+++ b/libical/configure.in
@@ -7,6 +7,11 @@ dnl Set the aux dir to .. (the toplevel evolution directory) so ylwrap
dnl is found in the correct directory for automake >= 1.5
AC_CONFIG_AUX_DIR(..)
+dnl subst in evolution's private directories
+AC_SUBST(privlibdir)
+AC_SUBST(privincludedir)
+AC_SUBST(privdatadir)
+
dnl Initialize maintainer mode
AM_MAINTAINER_MODE
@@ -25,10 +30,10 @@ AC_SUBST(AR)
AC_CHECK_PROGS(AR, ar aal, ar)
AC_CHECK_PROGS(PERL, perl5 perl)
-dnl AC_DEFINE(ICAL_ERRORS_ARE_FATAL,1)
-AC_DEFINE(ICAL_SAFESAVES,1)
-AC_DEFINE(ICAL_UNIX_NEWLINE,1)
-dnl AC_DEFINE(ICAL_NO_EMPTY_ARRAY_DECL)
+dnl AC_DEFINE(ICAL_ERRORS_ARE_FATAL,1,[Define to make icalerror_* calls abort instead of internally signalling an error])
+AC_DEFINE(ICAL_SAFESAVES,1,[Define to make icalcluster_commit() save to a temp file and mv to the original file instead of writing to the orig file directly])
+AC_DEFINE(ICAL_UNIX_NEWLINE,1,[Define to terminate lines with "\n" instead of "\r\n"])
+dnl AC_DEFINE(ICAL_NO_EMPTY_ARRAY_DECL,1,[Define to 1 if your compile does not like lines like: struct something foo[]])
dnl Checks for libraries.
dnl Replace `main' with a function in -lical:
@@ -51,7 +56,7 @@ dnl * Check for Python
dnl **************************************************
python_val=false
AC_ARG_ENABLE(python-bindings,
-[ --enable-python-bindings=[yes/no] Enable python bindings],,enable_python_bindings=yes)
+[ --enable-python-bindings=[yes/no] Enable python bindings],,enable_python_bindings=no)
if test "x$enable_python_bindings" = "xyes"; then
python_val=true
else