aboutsummaryrefslogtreecommitdiffstats
path: root/libibex/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-02-17 09:45:58 +0800
committerDan Winship <danw@src.gnome.org>2000-02-17 09:45:58 +0800
commit704369d07078a4a6a28552eaaad30d3758052d30 (patch)
tree083a7e6616ae37ffe15cf7215bfea1178293cce7 /libibex/Makefile.am
parentcd9df589eacaf47a085119fdb91e41a01eab9bb0 (diff)
downloadgsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar.gz
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar.bz2
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar.lz
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar.xz
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.tar.zst
gsoc2013-evolution-704369d07078a4a6a28552eaaad30d3758052d30.zip
automakify libibex
svn path=/trunk/; revision=1813
Diffstat (limited to 'libibex/Makefile.am')
-rw-r--r--libibex/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/libibex/Makefile.am b/libibex/Makefile.am
new file mode 100644
index 0000000000..6bbd72034f
--- /dev/null
+++ b/libibex/Makefile.am
@@ -0,0 +1,22 @@
+## Process this file with automake to produce Makefile.in
+
+lib_LTLIBRARIES = libibex.la
+
+libibex_la_SOURCES = file.c index.c find.c words.c
+
+include_HEADERS = ibex.h
+
+noinst_HEADERS = ibex_internal.h
+
+INCLUDES = -I$(srcdir) $(GLIB_CFLAGS) $(UNICODE_CFLAGS)
+
+
+noinst_PROGRAMS = mkindex lookup
+
+mkindex_SOURCES = mkindex.c
+
+mkindex_LDADD = libibex.la $(GLIB_LIBS) $(UNICODE_LIBS)
+
+lookup_SOURCES = lookup.c
+
+lookup_LDADD = libibex.la $(GLIB_LIBS) $(UNICODE_LIBS)