aboutsummaryrefslogtreecommitdiffstats
path: root/libevolution-utils/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-12-10 21:09:59 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-12-13 03:33:43 +0800
commitd09d8de870b6697c8a8b262e7e077b871a69b315 (patch)
tree3b718882e7a0bb0a996daf2967a033d91714c9b5 /libevolution-utils/Makefile.am
parentb61331ed03ac1c7a9b8614e25510040b9c60ae02 (diff)
downloadgsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.gz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.bz2
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.lz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.xz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.zst
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.zip
Consolidate base utility libraries into libeutil.
Evolution consists of entirely too many small utility libraries, which increases linking and loading time, places a burden on higher layers of the application (e.g. modules) which has to remember to link to all the small in-tree utility libraries, and makes it difficult to generate API documentation for these utility libraries in one Gtk-Doc module. Merge the following utility libraries under the umbrella of libeutil, and enforce a single-include policy on libeutil so we can reorganize the files as desired without disrupting its pseudo-public API. libemail-utils/libemail-utils.la libevolution-utils/libevolution-utils.la filter/libfilter.la widgets/e-timezone-dialog/libetimezonedialog.la widgets/menus/libmenus.la widgets/misc/libemiscwidgets.la widgets/table/libetable.la widgets/text/libetext.la This also merges libedataserverui from the Evolution-Data-Server module, since Evolution is its only consumer nowadays, and I'd like to make some improvements to those APIs without concern for backward-compatibility. And finally, start a Gtk-Doc module for libeutil. It's going to be a project just getting all the symbols _listed_ much less _documented_. But the skeletal structure is in place and I'm off to a good start.
Diffstat (limited to 'libevolution-utils/Makefile.am')
-rw-r--r--libevolution-utils/Makefile.am45
1 files changed, 0 insertions, 45 deletions
diff --git a/libevolution-utils/Makefile.am b/libevolution-utils/Makefile.am
deleted file mode 100644
index e785b8fc02..0000000000
--- a/libevolution-utils/Makefile.am
+++ /dev/null
@@ -1,45 +0,0 @@
-NULL =
-
-privsolib_LTLIBRARIES = libevolution-utils.la
-
-libevolution_utils_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
- -DEVOLUTION_UIDIR=\""$(uidir)"\" \
- $(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS) \
- $(NULL)
-
-libevolutionutilsincludedir = $(privincludedir)/libevolution-utils
-libevolutionutilsinclude_HEADERS = \
- e-alert.h \
- e-alert-dialog.h \
- e-alert-sink.h \
- e-xml-utils.h \
- evolution-util.h \
- $(NULL)
-
-libevolution_utils_la_SOURCES = \
- $(libevolutionutilsinclude_HEADERS) \
- e-alert.c \
- e-alert-dialog.c \
- e-alert-sink.c \
- e-xml-utils.c \
- evolution-util.c \
- $(NULL)
-
-libevolution_utils_la_LDFLAGS = -avoid-version $(NO_UNDEFINED)
-
-libevolution_utils_la_LIBADD = \
- $(EVOLUTION_DATA_SERVER_LIBS) \
- $(GNOME_PLATFORM_LIBS) \
- $(NULL)
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libevolution-utils.pc
-
-DISTCLEANFILES = $(pkgconfig_DATA)
-
--include $(top_srcdir)/git.mk