aboutsummaryrefslogtreecommitdiffstats
path: root/libemail-engine/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-12-31 23:22:54 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-12-31 23:22:54 +0800
commit800a5828e5bf36520d0d423612049a64c2e9f111 (patch)
tree726eaf23da1cdf840c0333ea6ea4b0b4d44549a1 /libemail-engine/Makefile.am
parent9f07dc68f8ec2e8d9d48c7a13f4edf74304d870d (diff)
downloadgsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar.gz
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar.bz2
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar.lz
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar.xz
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.tar.zst
gsoc2013-evolution-800a5828e5bf36520d0d423612049a64c2e9f111.zip
Move CamelSaslXOAuth2 to libemail-engine.
This now uses e_source_get_oauth2_access_token_sync() instead of talking directly to GNOME Online Accounts and therefore no longer has to live in the "online-accounts" module. The "online-accounts" module will be removed in Evolution 3.9.1, when we can require GNOME Online Accounts 3.8. Evolution 3.8 will still support older versions of GNOME Online Accounts, which use OAuth 1.0a tokens for Google authentication.
Diffstat (limited to 'libemail-engine/Makefile.am')
-rw-r--r--libemail-engine/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libemail-engine/Makefile.am b/libemail-engine/Makefile.am
index 215d48e934..60a8437c6e 100644
--- a/libemail-engine/Makefile.am
+++ b/libemail-engine/Makefile.am
@@ -25,6 +25,7 @@ libemail_engine_la_CPPFLAGS = \
libmailengineincludedir = $(privincludedir)/libemail-engine
libmailengineinclude_HEADERS = \
camel-null-store.h \
+ camel-sasl-xoauth2.h \
e-mail-authenticator.h \
e-mail-enums.h \
e-mail-enumtypes.h \
@@ -48,6 +49,7 @@ libmailengineinclude_HEADERS = \
libemail_engine_la_SOURCES = \
$(libmailengineinclude_HEADERS) \
camel-null-store.c \
+ camel-sasl-xoauth2.c \
e-mail-authenticator.c \
e-mail-enumtypes.c \
e-mail-folder-utils.c \