aboutsummaryrefslogtreecommitdiffstats
path: root/help/devel/calendar/cal-client/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-07-18 05:08:41 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-07-18 05:08:41 +0800
commite38c9ea0ed0f14ce563d355a0cea24460df26363 (patch)
treea54e0ce7fc2887466d6c37df39ac478f2aaa2c93 /help/devel/calendar/cal-client/Makefile.am
parentfab3b8e23e8ded8e8dba0c2300e49914e35d9145 (diff)
downloadgsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.gz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.bz2
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.lz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.xz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.zst
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.zip
New <book> toplevel for the Evolution Developer's Guide.
2000-07-17 Federico Mena Quintero <federico@helixcode.com> * evolution-devel-guide.sgml: New <book> toplevel for the Evolution Developer's Guide. * calendar/evolution-calendar.sgml: New <part> for the calendar developer's documentation. * calendar/architecture.sgml: New <chapter> for the calendar architecture. * calendar/reference.sgml: New <reference> for the calendar API reference. svn path=/trunk/; revision=4191
Diffstat (limited to 'help/devel/calendar/cal-client/Makefile.am')
-rw-r--r--help/devel/calendar/cal-client/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/help/devel/calendar/cal-client/Makefile.am b/help/devel/calendar/cal-client/Makefile.am
new file mode 100644
index 0000000000..44d43639a8
--- /dev/null
+++ b/help/devel/calendar/cal-client/Makefile.am
@@ -0,0 +1,76 @@
+## Process this file with automake to produce Makefile.in
+
+# The name of the module.
+DOC_MODULE=evolution-cal-client
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=evolution-cal-client.sgml
+
+# The directory containing the source code (if it contains documentation).
+DOC_SOURCE_DIR=$(EVOLUTION_DIR)/calendar/cal-client
+
+CFLAGS =" \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/libical/src/libical \
+ $(BONOBO_VFS_GNOME_CFLAGS) \
+ "
+
+LDFLAGS=" \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ $(top_builddir)/calendar/cal-client/.libs/libcal-client.a \
+ $(top_builddir)/calendar/cal-util/.libs/libcal-util.a \
+ $(top_builddir)/libical/src/libical/libical.a \
+ $(top_builddir)/libversit/.libs/libversit.al \
+ "
+
+HTML_DIR=$(datadir)/gnome/html
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+tmpl_sources = \
+ tmpl/cal-client.sgml \
+ tmpl/evolution-cal-client-unused.sgml
+
+evolution_cal_client_docdir = $(HTML_DIR)
+evolution_cal_client_doc_DATA = \
+ evolution-cal-client.hierarchy \
+ evolution-cal-client.types \
+ evolution-cal-client-decl.txt \
+ evolution-cal-client-sections.txt
+
+EXTRA_DIST = \
+ $(evolution_cal_client_doc_DATA)
+
+sgml/evolution-cal-client-doc.bottom: $(tmpl_sources)
+ $(MAKE) sgml
+
+scan:
+ -(cd $(srcdir) \
+ && env CFLAGS=$(CFLAGS) LDFLAGS=$(LDFLAGS) \
+ gtkdoc-scanobj --module=$(DOC_MODULE) \
+ && gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="cal-listener.h evolution-calendar.h" )
+
+templates: scan
+ cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE)
+
+sgml:
+ cd $(srcdir) \
+ && gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR)
+
+clean-local:
+ rm -f *~ *.bak *.signals *-unused.txt
+
+maintainer-clean-local: clean
+ cd $(srcdir) && rm -rf sgml $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
+
+dist-hook:
+ mkdir $(distdir)/sgml
+ mkdir $(distdir)/tmpl
+ -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+ -cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
+ -cp $(srcdir)/sgml/*.bottom $(srcdir)/sgml/*.top $(distdir)/sgml
+
+.PHONY : sgml templates scan