aboutsummaryrefslogtreecommitdiffstats
path: root/help/devel/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-12-20 02:13:34 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-12-20 02:13:34 +0800
commite90aa50001b8014497651628666455ab5c12c7b0 (patch)
tree059a7908ff4aeba98e11047faa68995080218c96 /help/devel/Makefile.am
parentde861766eded0c80ffbe050088043a16d7e4923f (diff)
downloadgsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar.gz
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar.bz2
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar.lz
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar.xz
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.tar.zst
gsoc2013-evolution-e90aa50001b8014497651628666455ab5c12c7b0.zip
Added proper dependency lists to the gtk-doc mess.
2000-12-19 Federico Mena Quintero <federico@helixcode.com> Added proper dependency lists to the gtk-doc mess. * calendar/cal-client/Makefile.am (TARGET_DIR): Removed unused variable. (SOURCE_FILES): New variable with the list of source files we depend on. (IGNORED_SOURCE_HEADERS): New variable with the headers we ignore for the gtkdoc-scan phase. (scan_generated): (tmpl_dependencies): (tmpl_sources): (tmpl_generated); (sgml_dependencies): (sgml_generated): Lists of stuff that is generated and that other stuff depends on. (all): Added the $(sgml_generated) as the final target. (install-data-local): Added an installation hook; gtk-doc seems to want some of its generated files to be installed. * calendar/cal-client/evolution-cal-client-sections.txt: Updated. * calendar/cal-util/Makefile.am: Made the same changes as for calendar/cal-client/Makefile.am. * calendar/cal-util/evolution-cal-util-sections.txt: Updated. * Makefile.am (local_entities): Added alarm-generation.sgml. (all): Made the main target be the html/index.html. svn path=/trunk/; revision=7084
Diffstat (limited to 'help/devel/Makefile.am')
-rw-r--r--help/devel/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/help/devel/Makefile.am b/help/devel/Makefile.am
index 0dd533057e..8e8ca1085c 100644
--- a/help/devel/Makefile.am
+++ b/help/devel/Makefile.am
@@ -22,6 +22,7 @@ content_files = \
# are used for dependency tracking.
local_entities = \
+ calendar/alarm-generation.sgml \
calendar/architecture.sgml \
calendar/evolution-calendar.sgml \
calendar/public-reference.sgml \
@@ -36,18 +37,15 @@ local_entities = \
EXTRA_DIST = \
$(content_files)
-all: evolution-devel-guide.html
+all: html/index.html
if ENABLE_GTK_DOC
-evolution-devel-guide.html: html/index.html
- -cd $(srcdir) && cp html/index.html evolution-devel-guide.html
-else
-evolution-devel-guide.html:
-endif
-
html/index.html: $(content_files) $(local_entities)
test -d $(srcdir)/html || mkdir $(srcdir)/html
-cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+else
+html/index.html:
+endif
clean-local:
rm -f *~ *.bak *.signals *-unused.txt