aboutsummaryrefslogtreecommitdiffstats
path: root/help/C/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-05-16 10:52:37 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-05-16 10:52:37 +0800
commitbc6aeab0b512f8753c75e9976ce205c48d4293f5 (patch)
tree594d283768d772ae4841bba92a678d4b2629b210 /help/C/Makefile.am
parentda08b32050f2ac15dcf0086b4f0b232e41afaab5 (diff)
downloadgsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar.gz
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar.bz2
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar.lz
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar.xz
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.tar.zst
gsoc2013-evolution-bc6aeab0b512f8753c75e9976ce205c48d4293f5.zip
Get the User guide and the Evolution FAQ to be installed into separate
directories. svn path=/trunk/; revision=9834
Diffstat (limited to 'help/C/Makefile.am')
-rw-r--r--help/C/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/help/C/Makefile.am b/help/C/Makefile.am
index cdf9d47dbe..67b44d27b3 100644
--- a/help/C/Makefile.am
+++ b/help/C/Makefile.am
@@ -38,23 +38,30 @@ dist-hook:
mkdir $(distdir)/evolution/stylesheet-images
-cp evolution/stylesheet-images/* $(distdir)/evolution/stylesheet-images
+# FIXME really messy here
install-data-local: evolution-guide evolution-faq
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/evolution-guide
-for file in $(srcdir)/evolution/*.html $(srcdir)/evolution/*.css; do \
basefile=`basename $$file`; \
- $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/$$basefile; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/evolution-guide/$$basefile; \
done
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/fig
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/evolution-faq
+ -for file in $(srcdir)/evolution-faq/*.html $(srcdir)/evolution-faq/*.css; do \
+ basefile=`basename $$file`; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/evolution-faq/$$basefile; \
+ done
+
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/evolution-guide/fig
-for file in $(srcdir)/fig/*.png; do \
basefile=`basename $$file`; \
- $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/fig/$$basefile; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/evolution-guide/fig/$$basefile; \
done
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/stylesheet-images
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/evolution-guide/stylesheet-images
-for file in $(srcdir)/evolution/stylesheet-images/*; do \
basefile=`basename $$file`; \
- $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/stylesheet-images/$$basefile; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/evolution-guide/stylesheet-images/$$basefile; \
done
evolution.ps: evolution.sgml