aboutsummaryrefslogtreecommitdiffstats
path: root/help/C/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-06-02 07:37:49 +0800
committerDan Winship <danw@src.gnome.org>2000-06-02 07:37:49 +0800
commit29a3e72881d3874ffaa4fd6dfce679239ea60bf8 (patch)
treea98e5272753962ab09c2e3940cd027f874e9df34 /help/C/Makefile.am
parent0432ec4d0ff907163693849b1c3ddb08ba3b33d3 (diff)
downloadgsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar.gz
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar.bz2
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar.lz
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar.xz
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.tar.zst
gsoc2013-evolution-29a3e72881d3874ffaa4fd6dfce679239ea60bf8.zip
build and install docs
svn path=/trunk/; revision=3345
Diffstat (limited to 'help/C/Makefile.am')
-rw-r--r--help/C/Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/help/C/Makefile.am b/help/C/Makefile.am
new file mode 100644
index 0000000000..d898720044
--- /dev/null
+++ b/help/C/Makefile.am
@@ -0,0 +1,54 @@
+evolution_helpdir = $(datadir)/gnome/help/evolution/C
+
+SGML_FILES = \
+ apx-authors.sgml \
+ apx-bugs.sgml \
+ apx-fdl.sgml \
+ apx-gloss.sgml \
+ config-prefs.sgml \
+ config-setupassist.sgml \
+ config-sync.sgml \
+ devel-action.sgml \
+ devel-component.sgml \
+ devel-script.sgml \
+ evolution-guide.sgml \
+ preface.sgml \
+ usage-calendar.sgml \
+ usage-contact.sgml \
+ usage-mail.sgml \
+ usage-mainwindow.sgml \
+ usage-sync.sgml
+
+
+EXTRA_DIST = \
+ $(SGML_FILES)
+
+all: evolution-guide
+
+evolution-guide: $(SGML_FILES)
+ -db2html evolution-guide.sgml
+
+dist-hook:
+ mkdir $(distdir)/evolution-guide
+ -cp evolution-guide/*.html evolution-guide/*.css \
+ $(distdir)/evolution-guide
+ mkdir $(distdir)/fig
+ -cp fig/*.png $(distdir)/fig
+
+install-data-local: evolution-guide
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(evolution_helpdir)/fig
+ -for file in $(srcdir)/evolution-guide/*.html $(srcdir)/evolution-guide/*.css; do \
+ basefile=`basename $$file`; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/$$basefile; \
+ done
+ -for file in $(srcdir)/fig/*.png; do \
+ basefile=`basename $$file`; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(evolution_helpdir)/fig/$$basefile; \
+ done
+
+evolution.ps: evolution.sgml
+ -db2ps $<
+
+evolution.rtf: evolution.sgml
+ -db2rtf $<
+