aboutsummaryrefslogtreecommitdiffstats
path: root/help/C/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2004-09-14 00:21:48 +0800
committerRodney Dawes <dobey@src.gnome.org>2004-09-14 00:21:48 +0800
commitd926df1ed5e62e35f362a91fe85bdfe2d476aab8 (patch)
treec56e0dbe1b507586fa22f64583a1c3965c7b4ce6 /help/C/Makefile.am
parenta9619acb9d91368b2e4d234621073348953f4949 (diff)
downloadgsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar.gz
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar.bz2
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar.lz
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar.xz
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.tar.zst
gsoc2013-evolution-d926df1ed5e62e35f362a91fe85bdfe2d476aab8.zip
Don't requires entities here
2004-09-13 Rodney Dawes <dobey@novell.com> * xmldocs.make: Don't requires entities here * C/Makefile.am: Add new figures to the list of images Generate versioned xml/omf files based on $(BASE_VERSION) Fix up CLEANFILES to include the stuff we generate * C/POTFILES.in: * C/apx-*.xml: * C/config-*.xml: * C/evolution-1.5-C.omf: * C/evolution-1.5.xml: * C/legal.xml: * C/menuref.xml: * C/preface.xml: * C/topic.dat: * C/usage-*.xml: Remove all of these files from CVS * C/evolution-C.omf: * C/evolution.xml: Add these files to replace the removed files above * C/figure/*_a.(png|gif): Add new screenshots svn path=/trunk/; revision=27253
Diffstat (limited to 'help/C/Makefile.am')
-rw-r--r--help/C/Makefile.am55
1 files changed, 35 insertions, 20 deletions
diff --git a/help/C/Makefile.am b/help/C/Makefile.am
index 25b037ab15..df8fc98c39 100644
--- a/help/C/Makefile.am
+++ b/help/C/Makefile.am
@@ -1,4 +1,19 @@
figs = \
+ figures/contacts_mainwindow_a.png \
+ figures/evo_account_info_a.png \
+ figures/evo_cal_callout_a.gif \
+ figures/evo_contacteditor_a.png \
+ figures/evo_email_a.png \
+ figures/evo_identity_a.png \
+ figures/evo_mail_callout_a.gif \
+ figures/evo_mail_callout_a.png \
+ figures/evo_newmess_a.png \
+ figures/evo_receive_setup2_a.png \
+ figures/evo_receive_setup_a.png \
+ figures/evo_rule_a.png \
+ figures/evo_send_setup_a.png \
+ figures/evo_timezone_a.png \
+ figures/mail_mainwindow_a.png \
figures/calendar.png \
figures/config-cal.png \
figures/config-mail.png \
@@ -26,27 +41,27 @@ figs = \
figures/summary.png \
figures/vfolder-createrule-fig.png
figdir = figures
-docname = evolution-1.5
+
+all: $(docname).xml $(omffile)
+
+doc_in_files = evolution.xml
+%-$(BASE_VERSION).xml: $(doc_in_files)
+ cp -f $< $@
+
+docname = evolution-$(BASE_VERSION)
lang = C
-omffile = evolution-1.5-C.omf
-entities = \
- apx-authors.xml \
- apx-bugs.xml \
- apx-fdl.xml \
- apx-gloss.xml \
- apx-gpl.xml \
- config-prefs.xml \
- config-sync.xml \
- legal.xml \
- menuref.xml \
- preface.xml \
- usage-calendar.xml \
- usage-contact.xml \
- usage-exchange.xml \
- usage-mail-org.xml \
- usage-mail.xml \
- usage-mainwindow.xml \
- usage-sync.xml
+
+omf_in_files = evolution-$(lang).omf
+%-$(BASE_VERSION)-$(lang).omf: $(omf_in_files)
+ cp -f $< $@
+omffile = evolution-$(BASE_VERSION)-C.omf
include $(top_srcdir)/help/xmldocs.make
dist-hook: app-dist-hook
+
+CLEANFILES += \
+ $(docname).xml \
+ omf_timestamp \
+ $(omffile).out \
+ $(omffile)
+