aboutsummaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-03-02 08:08:15 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-03-02 08:08:15 +0800
commitdff7aec3c3302c2191100ce22a8cf28959808c28 (patch)
tree339580ba53f70ec7337288b1a640d4e7c791c2f8 /filter/Makefile.am
parente5f5fa095678935bdd69e47421ecacf32377bdde (diff)
downloadgsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar.gz
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar.bz2
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar.lz
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar.xz
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.tar.zst
gsoc2013-evolution-dff7aec3c3302c2191100ce22a8cf28959808c28.zip
Automakeize the `filter' directory.
I wonder why we ever have non-Automake stuff in the repository at all. svn path=/trunk/; revision=2006
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
new file mode 100644
index 0000000000..ba6632471a
--- /dev/null
+++ b/filter/Makefile.am
@@ -0,0 +1,41 @@
+INCLUDES = \
+ -I $(top_srcdir) \
+ -I $(top_srcdir)/libibex \
+ -I $(top_srcdir)/camel \
+ -I $(top_srcdir)/e-util \
+ -I $(top_srcdir)/camel/providers/mbox \
+ -I $(GNOME_INCLUDEDIR) \
+ -I $(GTKHTML_CFLAGS)
+
+##
+
+noinst_PROGRAMS = \
+ filter-driver
+
+noinst_LTLIBRARIES = \
+ libfilter.la
+
+##
+
+filter_driver_SOURCES = \
+ filter-driver.c
+
+filter_driver_LDADD = \
+ libfilter.la \
+ ../camel/libcamel.la \
+ ../e-util/libeutil.la \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) \
+ $(INTLLIBS) \
+ $(PTHREAD_LIB) \
+ $(EXTRA_GNOME_LIBS)
+
+##
+
+libfilter_la_SOURCES = \
+ filter-arg-types.c \
+ filter-arg.c \
+ filter-xml.c \
+ filter-format.c \
+ filter-druid.c \
+ filter-editor.c