aboutsummaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@helixcode.com>2000-10-21 10:51:38 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2000-10-21 10:51:38 +0800
commit6d74595779416412b478dd4ae3d38dffd3f4baae (patch)
treef5793662a36daff8df54de77077193920fb5acc3 /filter/Makefile.am
parent3d17cca7ed57dcde3c6649e15d4ac7fe30174776 (diff)
downloadgsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar.gz
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar.bz2
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar.lz
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar.xz
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.tar.zst
gsoc2013-evolution-6d74595779416412b478dd4ae3d38dffd3f4baae.zip
Added filter-url.[c,h].
2000-10-20 Jeffrey Stedfast <fejj@helixcode.com> * Makefile.am: Added filter-url.[c,h]. * filter-message-search.c (get_source): New callback to get the source url of the message being filtered. (filter_message_search): Now takes a source argument. * filter-element.c (filter_element_new_type_name): Added code to handle URL types. * filter-url.[c,h]: New filter object to handle URLs (ie in the case of filtering on source url). FIXME: find a way to populate the source combo box (including mail-config.h breaks the build in the addressbook - how does including mail-tools.h not break the build???) * filtertypes.xml: Added the source filter type and added the move-to action. * filter-driver.c (do_move): New callback, a "Copy" action should just copy the message to another location while a Move should both copy the message to a new location and delete it from the source location. (do_delete): Set the deleted flag on the message info. (filter_driver_filter_message): Now returns void as we don't care if it was copied or not in the caller functions. Also check the CamelMessageInfo being passed in - if the message has been marked as deleted prior to being filtered, then return immediately as we don't want to apply filter actions to deleted messages. svn path=/trunk/; revision=6094
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 3a5dfe8e24..bf17f89614 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -52,6 +52,8 @@ libfilter_la_SOURCES = \
filter-rule.h \
filter-score.c \
filter-score.h \
+ filter-url.c \
+ filter-url.h \
rule-context.c \
rule-context.h \
score-context.c \
@@ -73,4 +75,3 @@ EXTRA_DIST = filtertypes.xml vfoldertypes.xml \
# basic rules.
filterdir = $(datadir)/evolution
filter_DATA = filtertypes.xml vfoldertypes.xml
-