aboutsummaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2003-01-03 01:06:18 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2003-01-03 01:06:18 +0800
commit901d85f456d0dca9353ad2cea5b366f08e202fcf (patch)
treef7877491dca77b4f75bcb7c64fabd1308e88b59a /filter/Makefile.am
parent070543d8c2e39b9680af03eeea0c7248dfb8dc83 (diff)
downloadgsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar.gz
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar.bz2
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar.lz
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar.xz
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.tar.zst
gsoc2013-evolution-901d85f456d0dca9353ad2cea5b366f08e202fcf.zip
Fixed to build with -DG_DISABLE_DEPRECATED and -DGTK_DISABLE_DEPRECATED
2003-01-02 Jeffrey Stedfast <fejj@ximian.com> Fixed to build with -DG_DISABLE_DEPRECATED and -DGTK_DISABLE_DEPRECATED svn path=/trunk/; revision=19202
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 0752a0bd18..cd13ed2a82 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -9,6 +9,8 @@ INCLUDES = \
-I $(top_srcdir)/shell \
-DFILTER_GLADEDIR=\"$(gladedir)\" \
-DG_LOG_DOMAIN=\"filter\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
$(LIBFILTER_CFLAGS)
noinst_LTLIBRARIES = \
@@ -39,6 +41,8 @@ libfilter_la_SOURCES = \
filter-int.h \
filter-label.c \
filter-label.h \
+ filter-marshal.c \
+ filter-marshal.h \
filter-option.c \
filter-option.h \
filter-part.c \
@@ -67,7 +71,7 @@ libfilter_la_SOURCES = \
libfilter_la_DEPENDENCIES = libfilter-i18n.h
EXTRA_DIST = filtertypes.xml vfoldertypes.xml \
- $(glade_DATA) libfilter-i18n.h
+ $(glade_DATA) libfilter-i18n.h filter-marshal.list
# basic rules.
filterdir = $(datadir)/evolution
@@ -78,3 +82,16 @@ libfilter-i18n.h: filtertypes.xml vfoldertypes.xml
cat $(srcdir)/filtertypes.xml $(srcdir)/vfoldertypes.xml | \
sed -n -e 's:.*<title>\(.*\)</title>:char *s = N_("\1");:p' | \
sort -u >> $@
+
+filter-marshal.h: filter-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=filter_marshal filter-marshal.list --header > filter-marshal.tmp \
+ && mv filter-marshal.tmp filter-marshal.h ) \
+ || ( rm -f filter-marshal.tmp && exit 1 )
+
+filter-marshal.c: filter-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=filter_marshal filter-marshal.list --body > filter-marshal.tmp \
+ && mv filter-marshal.tmp filter-marshal.c ) \
+ || ( rm -f filter-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = filter-marshal.c filter-marshal.h
+