aboutsummaryrefslogtreecommitdiffstats
path: root/filter/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-08-10 07:29:27 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-08-10 07:29:27 +0800
commita40159746efa236f154c57ff57f0fe1cb4ec9e5e (patch)
treec6d2d602194b54f1c734b1af7748709b630fed6a /filter/Makefile.am
parenta43c128c4bfe96ea35225cf1fb551c0cb8c5ac4a (diff)
downloadgsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar.gz
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar.bz2
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar.lz
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar.xz
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.tar.zst
gsoc2013-evolution-a40159746efa236f154c57ff57f0fe1cb4ec9e5e.zip
Use privsolib instead of privlib. On Unix they are the same, on Win32
2005-08-10 Tor Lillqvist <tml@novell.com> * Makefile.am: Use privsolib instead of privlib. On Unix they are the same, on Win32 privsolibdir is the same as libdir. Use the macro name EVOLUTION_GLADEDIR as in e-util/e-util-private.h instead of FILTER_GLADEDIR, so that the Win32 run-time path lookup mechanism works. Use NO_UNDEFINED. Link explicitly with the actual libraries used. * filter-datespec.c: No localtime_r() on Win32, but we can use plain localtime() which is thread-safe in the Microsoft C library. * filter-datespec.c * rule-editor.c: Include e-util-private.h for Win32 path run-time lookup. Use EVOLUTION_GLADEDIR instead of FILTER_GLADEDIR, and do the filter.glade pathname construction at run-time so it works even when EVOLUTION_GLADEDIR is a function call on Win32. svn path=/trunk/; revision=30063
Diffstat (limited to 'filter/Makefile.am')
-rw-r--r--filter/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/filter/Makefile.am b/filter/Makefile.am
index 8c287ee637..72cebb002a 100644
--- a/filter/Makefile.am
+++ b/filter/Makefile.am
@@ -5,11 +5,11 @@ INCLUDES = \
-I $(top_srcdir) \
-I $(top_srcdir)/e-util \
-I $(top_srcdir)/widgets/misc \
- -DFILTER_GLADEDIR=\"$(gladedir)\" \
+ -DEVOLUTION_GLADEDIR=\"$(gladedir)\" \
-DG_LOG_DOMAIN=\"filter\" \
$(LIBFILTER_CFLAGS)
-privlib_LTLIBRARIES = \
+privsolib_LTLIBRARIES = \
libfilter.la
libfilter_la_SOURCES = \
@@ -42,6 +42,13 @@ libfilter_la_SOURCES = \
rule-editor.c \
rule-editor.h
+libfilter_la_LDFLAGS = $(NO_UNDEFINED)
+
+libfilter_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(LIBFILTER_LIBS) \
+ $(REGEX_LIBS)
+
EXTRA_DIST = \
$(glade_DATA) \
filter.error.xml \