aboutsummaryrefslogtreecommitdiffstats
path: root/executive-summary/component/Makefile.am
diff options
context:
space:
mode:
authorIain Holmes <iain@src.gnome.org>2000-10-27 02:26:21 +0800
committerIain Holmes <iain@src.gnome.org>2000-10-27 02:26:21 +0800
commit45b1f2233e3e97510696b3775d38d0088a125c70 (patch)
treed6f8472f7c92dc46a09c471ec7a5c5ec7af505cc /executive-summary/component/Makefile.am
parentcbd931ab5192e39401ffe2fa609e6330107a0350 (diff)
downloadgsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar.gz
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar.bz2
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar.lz
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar.xz
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.tar.zst
gsoc2013-evolution-45b1f2233e3e97510696b3775d38d0088a125c70.zip
Added some functionality to the Executive Summary
Doesn't return to the top when refreshed Can execute programs when the user clicks on exec:// URLs and can compose an email when mailto:'s are clicked. svn path=/trunk/; revision=6205
Diffstat (limited to 'executive-summary/component/Makefile.am')
-rw-r--r--executive-summary/component/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/executive-summary/component/Makefile.am b/executive-summary/component/Makefile.am
index 0731ff40ca..496d70d2ac 100644
--- a/executive-summary/component/Makefile.am
+++ b/executive-summary/component/Makefile.am
@@ -19,27 +19,32 @@ INCLUDES = \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-executive-summary\"
-CLEANFILES = $(IDL_GENERATED)
+CLEANFILES = $(COMPOSER_GENERATED)
-IDL_GENERATED = \
- Executive-Summary.h \
- Executive-Summary-common.c \
- Executive-Summary-skels.c \
- Executive-Summary-stubs.c
+COMPOSER_GENERATED = \
+ Composer.h \
+ Composer-common.c \
+ Composer-skels.c \
+ Composer-stubs.c
-Executive-Summary-impl.o: Executive-Summary.h
+Composer-impl.o: Composer.h
-$(IDL_GENERATED):
+$(COMPOSER_GENERATED):
$(ORBIT_IDL) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
- -I$(srcdir) $(srcdir)/../idl/Executive-Summary.idl
+ -I$(srcdir) $(top_srcdir)/composer/Composer.idl
evolution_executive_summary_SOURCES = \
+ $(COMPOSER_GENERATED) \
component-factory.c \
component-factory.h \
e-summary.c \
e-summary.h \
e-summary-factory.c \
e-summary-factory.h \
+ e-summary-url.c \
+ e-summary-url.h \
+ e-summary-util.c \
+ e-summary-util.h \
main.c
evolution_executive_summary_LDADD = \