aboutsummaryrefslogtreecommitdiffstats
path: root/em-format/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
committerMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
commitf4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81 (patch)
tree1c0228db536f5fa0efc6e0f779bb86df610989d0 /em-format/Makefile.am
parent3acc45b10c9849aa5385a762b4d139472916dca1 (diff)
downloadgsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.gz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.bz2
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.lz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.xz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.zst
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.zip
Use -no-undefined on Linux too
There still left two things opened, search for KILL-BONOBO to find them. One is in calendar's Makefile.am, one in composer.
Diffstat (limited to 'em-format/Makefile.am')
-rw-r--r--em-format/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/em-format/Makefile.am b/em-format/Makefile.am
new file mode 100644
index 0000000000..e5d0fca3b6
--- /dev/null
+++ b/em-format/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(EVOLUTION_MAIL_CFLAGS)
+
+noinst_LTLIBRARIES = libemformat.la
+
+libemformat_la_SOURCES = \
+ em-format.h \
+ em-format.c \
+ em-format-quote.h \
+ em-format-quote.c \
+ em-stripsig-filter.c \
+ em-stripsig-filter.h
+
+libemformat_la_LDFLAGS = -avoid-version $(NO_UNDEFINED)
+
+libemformat_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(EVOLUTION_MAIL_LIBS)
+
+-include $(top_srcdir)/git.mk