aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-11-07 02:33:55 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-11-08 03:01:46 +0800
commitaa66a17e401d73cbe394ed7f99bf73350e9b938b (patch)
tree305c80be39d688cf8386b5e123f3df631f2cfc84 /e-util/Makefile.am
parentb2dd9c153519d315f96bfd760e91a6f6b32affd6 (diff)
downloadgsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar.gz
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar.bz2
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar.lz
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar.xz
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.tar.zst
gsoc2013-evolution-aa66a17e401d73cbe394ed7f99bf73350e9b938b.zip
Test drive EIOActivity with a simple asynchronous function.
Rename e-fsutils to e-file-utils. This is where we'll add asynchronous functions for common file I/O operations with EActivity integration. Start with e_file_replace_contents_async() (and corresponding finish() function). This is a simple wrapper for g_file_replace_contents_async() which also returns an EActivity. It replaces e_write_file_uri(). Also redesign EIOActivity to -contain- a GAsyncResult rather than implement the interface for itself. This is easier for now but I may change my mind again when I figure out how to tie centralized error reporting into the EActivity framework.
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index bc5e7cd4fc..ecc3220f29 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -24,8 +24,8 @@ eutilinclude_HEADERS = \
e-dialog-widgets.h \
e-error.h \
e-event.h \
+ e-file-utils.h \
e-folder-map.h \
- e-fsutils.h \
e-html-utils.h \
e-icon-factory.h \
e-import.h \
@@ -98,8 +98,8 @@ libeutil_la_SOURCES = \
e-dialog-widgets.c \
e-error.c \
e-event.c \
+ e-file-utils.c \
e-folder-map.c \
- e-fsutils.c \
e-html-utils.c \
e-icon-factory.c \
e-import.c \