aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Loper <mloper@src.gnome.org>2000-04-24 11:10:30 +0800
committerMatthew Loper <mloper@src.gnome.org>2000-04-24 11:10:30 +0800
commit7c309e43b25b9de136c5329d7fc041baeaf841c6 (patch)
treea97f3dbc1e924cbd1f6e2caa66ebffb337cc1b58 /e-util/Makefile.am
parent0fe51af01075beb777894bacca9e98aeef3f860a (diff)
downloadgsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar.gz
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar.bz2
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar.lz
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar.xz
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.tar.zst
gsoc2013-evolution-7c309e43b25b9de136c5329d7fc041baeaf841c6.zip
+ * widgets/Makefile.am: Added e-paned directory.
+ + * default_user/Makefile.am: new file. + + * default_user/Main_Shortcuts.xml: New file; is used to fill the + shortcut bar's "main shortcuts" pane. + + * default_user/Other_Shortcuts.xml: New file, used to fill the + shortcut bar's "other shortcuts" pane. + + * default_user/Inbox.mbox: New file. This is the first message a + new user will see when they fire up Evolution. Needs work. + + * Makefile.am: added default_user directory. + * configure.in: same. + + * e-paned.c: New file. Makes a GtkPaned with more than two + children. + * e-paned.h: same. + + * Makefile.am: added e-paned.[ch]. + + * e-shell-view.h: Added hpaned and treeview widgets to + EShellView. Added e_shell_view_toggle_shortcut_bar() and + e_shell_view_toggle_treeview(). + + * e-shell-view.c (e_shell_view_setup_shortcut_display): Use EPaned + widget to house our shortcut bar. + (e_shell_view_toggle_shortcut_bar): New function; toggles whether + the shortcut bar is showing. + (e_shell_view_toggle_treeview): Same, for the treeview (NYI). + (e_shell_view_new): Put the notebook view in our EPaned widget. + + * e-shell-view-menu.c (esv_cmd_toggle_shortcut_bar): New function; + toggles whether the shortcut bar is viewed. + (esv_cmd_toggle_treeview): Same, but with the treeview. Added + menuitems in the "view" menu to allow access to the above. + svn path=/trunk/; revision=2575
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 77a6c5eec0..3dc32f3ab3 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -19,4 +19,6 @@ libeutil_la_SOURCES = \
e-xml-utils.c \
e-xml-utils.h \
e-sexp.c \
- e-sexp.h
+ e-sexp.h \
+ e-paned.c \
+ e-paned.h