aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-04-19 20:15:03 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-04-24 08:06:01 +0800
commit5991b04ac5b48980f4d384951d619b3ec696e17f (patch)
treedebdc2e3667ccfa13af2248cc8c0f1536d907a88 /e-util/Makefile.am
parentc64602b39797e4d1ffdc23766b2caaf5a0be000b (diff)
downloadgsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar.gz
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar.bz2
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar.lz
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar.xz
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.tar.zst
gsoc2013-evolution-5991b04ac5b48980f4d384951d619b3ec696e17f.zip
Add EPhotoSource interface.
EPhotoSource is an interface used to extend the functionality of EPhotoCache. You can add an object implementing EPhotoSource to an EPhotoCache with e_photo_cache_add_photo_source() and remove it with e_photo_cache_remove_photo_source(). When EPhotoCache needs a photo for an email address, it will invoke e_photo_source_get_photo() on all available EPhotoSource objects simultaneously and select one photo.
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index e7a8f794cc..933bdd85fc 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -216,6 +216,7 @@ eutilinclude_HEADERS = \
e-paned.h \
e-passwords.h \
e-photo-cache.h \
+ e-photo-source.h \
e-picture-gallery.h \
e-plugin-ui.h \
e-plugin.h \
@@ -464,6 +465,7 @@ libeutil_la_SOURCES = \
e-paned.c \
e-passwords.c \
e-photo-cache.c \
+ e-photo-source.c \
e-picture-gallery.c \
e-plugin-ui.c \
e-plugin.c \