aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-04-24 04:50:54 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-04-24 04:50:54 +0800
commit0006bfb58ac91bac0768590827bd3dabba72c638 (patch)
treecfac8f30da40622fe1cbc56ce5518911e38e0028 /e-util/Makefile.am
parent6350c087b31b10d8d05b774e1829b3ff80812f90 (diff)
downloadgsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar.gz
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar.bz2
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar.lz
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar.xz
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.tar.zst
gsoc2013-evolution-0006bfb58ac91bac0768590827bd3dabba72c638.zip
Bug 577898 – Port ExoBinding to Evolution
Port Xfce's ExoBinding API to Evolution as EBinding. What this does is allow you to bind two GObject properties together such that their values are automatically kept in sync. The API also supports transformation functions, such as boolean inversion. I use this API heavily on the kill-bonobo branch and also in the attachment UI rewrite, so I'm merging this feature early.
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 73665a3516..ee54891c1d 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -41,6 +41,7 @@ privsolib_LTLIBRARIES = libeutil.la libeconduit.la
eutilinclude_HEADERS = \
e-bconf-map.h \
+ e-binding.h \
e-categories-config.h \
e-config.h \
e-config-listener.h \
@@ -82,6 +83,7 @@ eutilinclude_HEADERS = \
libeutil_la_SOURCES = \
$(eutilinclude_HEADERS) \
e-bconf-map.c \
+ e-binding.c \
e-categories-config.c \
e-config.c \
e-config-listener.c \