aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-12-10 21:09:59 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-12-13 03:33:43 +0800
commitd09d8de870b6697c8a8b262e7e077b871a69b315 (patch)
tree3b718882e7a0bb0a996daf2967a033d91714c9b5 /e-util/Makefile.am
parentb61331ed03ac1c7a9b8614e25510040b9c60ae02 (diff)
downloadgsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.gz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.bz2
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.lz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.xz
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.tar.zst
gsoc2013-evolution-d09d8de870b6697c8a8b262e7e077b871a69b315.zip
Consolidate base utility libraries into libeutil.
Evolution consists of entirely too many small utility libraries, which increases linking and loading time, places a burden on higher layers of the application (e.g. modules) which has to remember to link to all the small in-tree utility libraries, and makes it difficult to generate API documentation for these utility libraries in one Gtk-Doc module. Merge the following utility libraries under the umbrella of libeutil, and enforce a single-include policy on libeutil so we can reorganize the files as desired without disrupting its pseudo-public API. libemail-utils/libemail-utils.la libevolution-utils/libevolution-utils.la filter/libfilter.la widgets/e-timezone-dialog/libetimezonedialog.la widgets/menus/libmenus.la widgets/misc/libemiscwidgets.la widgets/table/libetable.la widgets/text/libetext.la This also merges libedataserverui from the Evolution-Data-Server module, since Evolution is its only consumer nowadays, and I'd like to make some improvements to those APIs without concern for backward-compatibility. And finally, start a Gtk-Doc module for libeutil. It's going to be a project just getting all the symbols _listed_ much less _documented_. But the skeletal structure is in place and I'm off to a good start.
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am755
1 files changed, 637 insertions, 118 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 4464f93045..15a9bcd8ac 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
eutilincludedir = $(privincludedir)/e-util
ecpsdir = $(privdatadir)/ecps
ruledir = $(privdatadir)
@@ -22,133 +24,650 @@ e-marshal.c: e-marshal.list
ENUM_GENERATED = e-util-enumtypes.h e-util-enumtypes.c
MARSHAL_GENERATED = e-marshal.c e-marshal.h
-if OS_WIN32
-PLATFORM_SOURCES = e-win32-reloc.c e-win32-defaults.c e-win32-defaults.h
-endif
+error_DATA = \
+ e-system.error \
+ filter.error \
+ widgets.error \
+ $(NULL)
+errordir = $(privdatadir)/errors
+@EVO_PLUGIN_RULE@
+
+ui_DATA = \
+ e-send-options.ui \
+ e-table-config.ui \
+ e-timezone-dialog.ui \
+ filter.ui \
+ gal-define-views.ui \
+ gal-view-instance-save-as-dialog.ui \
+ gal-view-new-dialog.ui \
+ $(NULL)
+
+xpm_icons = \
+ arrow-down.xpm \
+ arrow-up.xpm \
+ check-empty.xpm \
+ check-filled.xpm \
+ tree-expanded.xpm \
+ tree-unexpanded.xpm \
+ $(NULL)
privsolib_LTLIBRARIES = libeutil.la
-eutilinclude_HEADERS = \
- e-activity.h \
- e-bit-array.h \
- e-categories-config.h \
- e-charset.h \
- e-config.h \
- e-datetime-format.h \
- e-dialog-utils.h \
- e-dialog-widgets.h \
- e-event.h \
- e-file-request.h \
- e-file-utils.h \
- e-html-utils.h \
- e-icon-factory.h \
- e-import.h \
- e-marshal.h \
- e-mktemp.h \
- e-poolv.h \
- e-print.h \
- e-plugin.h \
- e-plugin-ui.h \
- e-selection.h \
- e-sorter.h \
- e-sorter-array.h \
- e-source-util.h \
- e-stock-request.h \
- e-text-event-processor-emacs-like.h \
- e-text-event-processor-types.h \
- e-text-event-processor.h \
- e-ui-manager.h \
- e-util.h \
- e-util-enums.h \
- e-util-enumtypes.h \
- e-unicode.h
-
-libeutil_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -I$(top_srcdir)/widgets \
- -DEVOLUTION_BINDIR=\""$(bindir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
- -DEVOLUTION_HELPDIR=\""$(evolutionhelpdir)"\" \
- -DEVOLUTION_ICONDIR=\""$(icondir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
- -DEVOLUTION_LIBDIR=\""$(datadir)"\" \
- -DEVOLUTION_LIBEXECDIR=\""$(privlibexecdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_MODULEDIR=\""$(moduledir)"\" \
- -DEVOLUTION_PLUGINDIR=\""$(plugindir)"\" \
- -DEVOLUTION_PREFIX=\""$(prefix)"\" \
- -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
- -DEVOLUTION_SOUNDDIR=\""$(soundsdir)"\" \
- -DEVOLUTION_SYSCONFDIR=\""$(sysconfdir)"\" \
- -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
- -DEVOLUTION_UIDIR=\""$(uidir)"\" \
- -DEVOLUTION_RULEDIR=\"$(ruledir)\" \
- -DG_LOG_DOMAIN=\"e-utils\" \
- $(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS)
-
-libeutil_la_SOURCES = \
- $(eutilinclude_HEADERS) \
- e-activity.c \
- e-bit-array.c \
- e-categories-config.c \
- e-charset.c \
- e-config.c \
- e-datetime-format.c \
- e-dialog-utils.c \
- e-dialog-widgets.c \
- e-event.c \
- e-file-request.c \
- e-file-utils.c \
- e-html-utils.c \
- e-icon-factory.c \
- e-import.c \
- e-marshal.c \
- e-mktemp.c \
- e-poolv.c \
- e-plugin.c \
- e-plugin-ui.c \
- e-print.c \
- e-selection.c \
- e-sorter.c \
- e-sorter-array.c \
- e-source-util.c \
- e-stock-request.c \
- e-text-event-processor-emacs-like.c \
- e-text-event-processor.c \
- e-ui-manager.c \
- e-util.c \
- e-unicode.c \
- e-util-enumtypes.c \
- e-util-private.h \
- $(PLATFORM_SOURCES)
+noinst_PROGRAMS = \
+ evolution-source-viewer \
+ test-calendar \
+ test-category-completion \
+ test-contact-store \
+ test-dateedit \
+ test-mail-signatures \
+ test-name-selector \
+ test-preferences-window \
+ test-source-combo-box \
+ test-source-config \
+ test-source-selector \
+ $(NULL)
+
+libeutil_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DLIBEUTIL_COMPILATION \
+ -DEVOLUTION_BINDIR=\""$(bindir)"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
+ -DEVOLUTION_HELPDIR=\""$(evolutionhelpdir)"\" \
+ -DEVOLUTION_ICONDIR=\""$(icondir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_LIBDIR=\""$(datadir)"\" \
+ -DEVOLUTION_LIBEXECDIR=\""$(privlibexecdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_MODULEDIR=\""$(moduledir)"\" \
+ -DEVOLUTION_PLUGINDIR=\""$(plugindir)"\" \
+ -DEVOLUTION_PREFIX=\""$(prefix)"\" \
+ -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ -DEVOLUTION_SOUNDDIR=\""$(soundsdir)"\" \
+ -DEVOLUTION_SYSCONFDIR=\""$(sysconfdir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
+ -DEVOLUTION_UIDIR=\""$(uidir)"\" \
+ -DEVOLUTION_RULEDIR=\"$(ruledir)\" \
+ -DG_LOG_DOMAIN=\"libeutil\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(CHAMPLAIN_CFLAGS) \
+ $(GEO_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+eutilinclude_HEADERS = \
+ e-util.h \
+ e-action-combo-box.h \
+ e-activity-bar.h \
+ e-activity-proxy.h \
+ e-activity.h \
+ e-alarm-selector.h \
+ e-alert-bar.h \
+ e-alert-dialog.h \
+ e-alert-sink.h \
+ e-alert.h \
+ e-attachment-bar.h \
+ e-attachment-button.h \
+ e-attachment-dialog.h \
+ e-attachment-handler-image.h \
+ e-attachment-handler-sendto.h \
+ e-attachment-handler.h \
+ e-attachment-icon-view.h \
+ e-attachment-paned.h \
+ e-attachment-store.h \
+ e-attachment-tree-view.h \
+ e-attachment-view.h \
+ e-attachment.h \
+ e-auth-combo-box.h \
+ e-autocomplete-selector.h \
+ e-bit-array.h \
+ e-book-source-config.h \
+ e-buffer-tagger.h \
+ e-cal-source-config.h \
+ e-calendar-item.h \
+ e-calendar.h \
+ e-canvas-background.h \
+ e-canvas-utils.h \
+ e-canvas-vbox.h \
+ e-canvas.h \
+ e-categories-config.h \
+ e-categories-dialog.h \
+ e-categories-editor.h \
+ e-categories-selector.h \
+ e-category-completion.h \
+ e-category-editor.h \
+ e-cell-checkbox.h \
+ e-cell-combo.h \
+ e-cell-date-edit.h \
+ e-cell-date.h \
+ e-cell-hbox.h \
+ e-cell-number.h \
+ e-cell-percent.h \
+ e-cell-pixbuf.h \
+ e-cell-popup.h \
+ e-cell-renderer-color.h \
+ e-cell-size.h \
+ e-cell-text.h \
+ e-cell-toggle.h \
+ e-cell-tree.h \
+ e-cell-vbox.h \
+ e-cell.h \
+ e-charset-combo-box.h \
+ e-charset.h \
+ e-client-utils.h \
+ e-config.h \
+ e-contact-map-window.h \
+ e-contact-map.h \
+ e-contact-marker.h \
+ e-contact-store.h \
+ e-dateedit.h \
+ e-datetime-format.h \
+ e-destination-store.h \
+ e-dialog-utils.h \
+ e-dialog-widgets.h \
+ e-event.h \
+ e-file-request.h \
+ e-file-utils.h \
+ e-filter-code.h \
+ e-filter-color.h \
+ e-filter-datespec.h \
+ e-filter-element.h \
+ e-filter-file.h \
+ e-filter-input.h \
+ e-filter-int.h \
+ e-filter-option.h \
+ e-filter-part.h \
+ e-filter-rule.h \
+ e-focus-tracker.h \
+ e-html-utils.h \
+ e-icon-factory.h \
+ e-image-chooser.h \
+ e-import-assistant.h \
+ e-import.h \
+ e-interval-chooser.h \
+ e-mail-identity-combo-box.h \
+ e-mail-signature-combo-box.h \
+ e-mail-signature-editor.h \
+ e-mail-signature-manager.h \
+ e-mail-signature-preview.h \
+ e-mail-signature-script-dialog.h \
+ e-mail-signature-tree-view.h \
+ e-map.h \
+ e-marshal.h \
+ e-menu-tool-action.h \
+ e-menu-tool-button.h \
+ e-misc-utils.h \
+ e-mktemp.h \
+ e-name-selector-dialog.h \
+ e-name-selector-entry.h \
+ e-name-selector-list.h \
+ e-name-selector-model.h \
+ e-name-selector.h \
+ e-online-button.h \
+ e-paned.h \
+ e-passwords.h \
+ e-picture-gallery.h \
+ e-plugin-ui.h \
+ e-plugin.h \
+ e-poolv.h \
+ e-popup-action.h \
+ e-popup-menu.h \
+ e-port-entry.h \
+ e-preferences-window.h \
+ e-preview-pane.h \
+ e-print.h \
+ e-printable.h \
+ e-reflow-model.h \
+ e-reflow.h \
+ e-rule-context.h \
+ e-rule-editor.h \
+ e-search-bar.h \
+ e-selectable.h \
+ e-selection-model-array.h \
+ e-selection-model-simple.h \
+ e-selection-model.h \
+ e-selection.h \
+ e-send-options.h \
+ e-sorter-array.h \
+ e-sorter.h \
+ e-source-combo-box.h \
+ e-source-config-backend.h \
+ e-source-config-dialog.h \
+ e-source-config.h \
+ e-source-selector-dialog.h \
+ e-source-selector.h \
+ e-source-util.h \
+ e-spell-entry.h \
+ e-stock-request.h \
+ e-table-click-to-add.h \
+ e-table-col-dnd.h \
+ e-table-col.h \
+ e-table-column-specification.h \
+ e-table-config.h \
+ e-table-defines.h \
+ e-table-extras.h \
+ e-table-field-chooser-dialog.h \
+ e-table-field-chooser-item.h \
+ e-table-field-chooser.h \
+ e-table-group-container.h \
+ e-table-group-leaf.h \
+ e-table-group.h \
+ e-table-header-item.h \
+ e-table-header-utils.h \
+ e-table-header.h \
+ e-table-item.h \
+ e-table-memory-callbacks.h \
+ e-table-memory-store.h \
+ e-table-memory.h \
+ e-table-model.h \
+ e-table-one.h \
+ e-table-search.h \
+ e-table-selection-model.h \
+ e-table-sort-info.h \
+ e-table-sorted-variable.h \
+ e-table-sorted.h \
+ e-table-sorter.h \
+ e-table-sorting-utils.h \
+ e-table-specification.h \
+ e-table-state.h \
+ e-table-subset-variable.h \
+ e-table-subset.h \
+ e-table-utils.h \
+ e-table-without.h \
+ e-table.h \
+ e-text-event-processor-emacs-like.h \
+ e-text-event-processor-types.h \
+ e-text-event-processor.h \
+ e-text-model-repos.h \
+ e-text-model.h \
+ e-text.h \
+ e-timezone-dialog.h \
+ e-tree-memory-callbacks.h \
+ e-tree-memory.h \
+ e-tree-model-generator.h \
+ e-tree-model.h \
+ e-tree-selection-model.h \
+ e-tree-sorted.h \
+ e-tree-table-adapter.h \
+ e-tree.h \
+ e-ui-manager.h \
+ e-unicode.h \
+ e-url-entry.h \
+ e-util-enums.h \
+ e-util-enumtypes.h \
+ e-web-view-gtkhtml.h \
+ e-web-view-preview.h \
+ e-web-view.h \
+ e-xml-utils.h \
+ ea-calendar-cell.h \
+ ea-calendar-item.h \
+ ea-cell-table.h \
+ ea-factory.h \
+ ea-widgets.h \
+ gal-a11y-e-cell-popup.h \
+ gal-a11y-e-cell-registry.h \
+ gal-a11y-e-cell-toggle.h \
+ gal-a11y-e-cell-tree.h \
+ gal-a11y-e-cell-vbox.h \
+ gal-a11y-e-cell.h \
+ gal-a11y-e-table-click-to-add-factory.h \
+ gal-a11y-e-table-click-to-add.h \
+ gal-a11y-e-table-column-header.h \
+ gal-a11y-e-table-factory.h \
+ gal-a11y-e-table-item-factory.h \
+ gal-a11y-e-table-item.h \
+ gal-a11y-e-table.h \
+ gal-a11y-e-text-factory.h \
+ gal-a11y-e-text.h \
+ gal-a11y-e-tree-factory.h \
+ gal-a11y-e-tree.h \
+ gal-a11y-factory.h \
+ gal-a11y-util.h \
+ gal-define-views-dialog.h \
+ gal-define-views-model.h \
+ gal-view-collection.h \
+ gal-view-etable.h \
+ gal-view-factory-etable.h \
+ gal-view-factory.h \
+ gal-view-instance-save-as-dialog.h \
+ gal-view-instance.h \
+ gal-view-new-dialog.h \
+ gal-view.h \
+ $(NULL)
+
+if OS_WIN32
+PLATFORM_SOURCES = \
+ e-win32-reloc.c \
+ e-win32-defaults.c \
+ e-win32-defaults.h \
+ $(NULL)
+endif
+
+libeutil_la_SOURCES = \
+ $(eutilinclude_HEADERS) \
+ e-action-combo-box.c \
+ e-activity-bar.c \
+ e-activity-proxy.c \
+ e-activity.c \
+ e-alarm-selector.c \
+ e-alert-bar.c \
+ e-alert-dialog.c \
+ e-alert-sink.c \
+ e-alert.c \
+ e-attachment-bar.c \
+ e-attachment-button.c \
+ e-attachment-dialog.c \
+ e-attachment-handler-image.c \
+ e-attachment-handler-sendto.c \
+ e-attachment-handler.c \
+ e-attachment-icon-view.c \
+ e-attachment-paned.c \
+ e-attachment-store.c \
+ e-attachment-tree-view.c \
+ e-attachment-view.c \
+ e-attachment.c \
+ e-auth-combo-box.c \
+ e-autocomplete-selector.c \
+ e-bit-array.c \
+ e-book-source-config.c \
+ e-buffer-tagger.c \
+ e-cal-source-config.c \
+ e-calendar-item.c \
+ e-calendar.c \
+ e-canvas-background.c \
+ e-canvas-utils.c \
+ e-canvas-vbox.c \
+ e-canvas.c \
+ e-categories-config.c \
+ e-categories-dialog.c \
+ e-categories-editor.c \
+ e-categories-selector.c \
+ e-category-completion.c \
+ e-category-editor.c \
+ e-cell-checkbox.c \
+ e-cell-combo.c \
+ e-cell-date-edit.c \
+ e-cell-date.c \
+ e-cell-hbox.c \
+ e-cell-number.c \
+ e-cell-percent.c \
+ e-cell-pixbuf.c \
+ e-cell-popup.c \
+ e-cell-renderer-color.c \
+ e-cell-size.c \
+ e-cell-text.c \
+ e-cell-toggle.c \
+ e-cell-tree.c \
+ e-cell-vbox.c \
+ e-cell.c \
+ e-charset-combo-box.c \
+ e-charset.c \
+ e-client-utils.c \
+ e-config.c \
+ e-contact-map-window.c \
+ e-contact-map.c \
+ e-contact-marker.c \
+ e-contact-store.c \
+ e-dateedit.c \
+ e-datetime-format.c \
+ e-destination-store.c \
+ e-dialog-utils.c \
+ e-dialog-widgets.c \
+ e-event.c \
+ e-file-request.c \
+ e-file-utils.c \
+ e-filter-code.c \
+ e-filter-color.c \
+ e-filter-datespec.c \
+ e-filter-element.c \
+ e-filter-file.c \
+ e-filter-input.c \
+ e-filter-int.c \
+ e-filter-option.c \
+ e-filter-part.c \
+ e-filter-rule.c \
+ e-focus-tracker.c \
+ e-html-utils.c \
+ e-icon-factory.c \
+ e-image-chooser.c \
+ e-import-assistant.c \
+ e-import.c \
+ e-interval-chooser.c \
+ e-mail-identity-combo-box.c \
+ e-mail-signature-combo-box.c \
+ e-mail-signature-editor.c \
+ e-mail-signature-manager.c \
+ e-mail-signature-preview.c \
+ e-mail-signature-script-dialog.c \
+ e-mail-signature-tree-view.c \
+ e-map.c \
+ e-marshal.c \
+ e-menu-tool-action.c \
+ e-menu-tool-button.c \
+ e-misc-utils.c \
+ e-mktemp.c \
+ e-name-selector-dialog.c \
+ e-name-selector-entry.c \
+ e-name-selector-list.c \
+ e-name-selector-model.c \
+ e-name-selector.c \
+ e-online-button.c \
+ e-paned.c \
+ e-passwords.c \
+ e-picture-gallery.c \
+ e-plugin-ui.c \
+ e-plugin.c \
+ e-poolv.c \
+ e-popup-action.c \
+ e-popup-menu.c \
+ e-port-entry.c \
+ e-preferences-window.c \
+ e-preview-pane.c \
+ e-print.c \
+ e-printable.c \
+ e-reflow-model.c \
+ e-reflow.c \
+ e-rule-context.c \
+ e-rule-editor.c \
+ e-search-bar.c \
+ e-selectable.c \
+ e-selection-model-array.c \
+ e-selection-model-simple.c \
+ e-selection-model.c \
+ e-selection.c \
+ e-send-options.c \
+ e-sorter-array.c \
+ e-sorter.c \
+ e-source-combo-box.c \
+ e-source-config-backend.c \
+ e-source-config-dialog.c \
+ e-source-config.c \
+ e-source-selector-dialog.c \
+ e-source-selector.c \
+ e-source-util.c \
+ e-spell-entry.c \
+ e-stock-request.c \
+ e-table-click-to-add.c \
+ e-table-col.c \
+ e-table-column-specification.c \
+ e-table-config.c \
+ e-table-extras.c \
+ e-table-field-chooser-dialog.c \
+ e-table-field-chooser-item.c \
+ e-table-field-chooser.c \
+ e-table-group-container.c \
+ e-table-group-leaf.c \
+ e-table-group.c \
+ e-table-header-item.c \
+ e-table-header-utils.c \
+ e-table-header.c \
+ e-table-item.c \
+ e-table-memory-callbacks.c \
+ e-table-memory-store.c \
+ e-table-memory.c \
+ e-table-model.c \
+ e-table-one.c \
+ e-table-search.c \
+ e-table-selection-model.c \
+ e-table-sort-info.c \
+ e-table-sorted-variable.c \
+ e-table-sorted.c \
+ e-table-sorter.c \
+ e-table-sorting-utils.c \
+ e-table-specification.c \
+ e-table-state.c \
+ e-table-subset-variable.c \
+ e-table-subset.c \
+ e-table-utils.c \
+ e-table-without.c \
+ e-table.c \
+ e-text-event-processor-emacs-like.c \
+ e-text-event-processor.c \
+ e-text-model-repos.c \
+ e-text-model.c \
+ e-text.c \
+ e-timezone-dialog.c \
+ e-tree-memory-callbacks.c \
+ e-tree-memory.c \
+ e-tree-model-generator.c \
+ e-tree-model.c \
+ e-tree-selection-model.c \
+ e-tree-sorted.c \
+ e-tree-table-adapter.c \
+ e-tree.c \
+ e-ui-manager.c \
+ e-unicode.c \
+ e-url-entry.c \
+ e-util-enumtypes.c \
+ e-util-private.h \
+ e-web-view-gtkhtml.c \
+ e-web-view-preview.c \
+ e-web-view.c \
+ e-xml-utils.c \
+ ea-calendar-cell.c \
+ ea-calendar-item.c \
+ ea-cell-table.c \
+ ea-widgets.c \
+ gal-a11y-e-cell-popup.c \
+ gal-a11y-e-cell-registry.c \
+ gal-a11y-e-cell-toggle.c \
+ gal-a11y-e-cell-tree.c \
+ gal-a11y-e-cell-vbox.c \
+ gal-a11y-e-cell.c \
+ gal-a11y-e-table-click-to-add-factory.c \
+ gal-a11y-e-table-click-to-add.c \
+ gal-a11y-e-table-column-header.c \
+ gal-a11y-e-table-factory.c \
+ gal-a11y-e-table-item-factory.c \
+ gal-a11y-e-table-item.c \
+ gal-a11y-e-table.c \
+ gal-a11y-e-text-factory.c \
+ gal-a11y-e-text.c \
+ gal-a11y-e-tree-factory.c \
+ gal-a11y-e-tree.c \
+ gal-a11y-util.c \
+ gal-define-views-dialog.c \
+ gal-define-views-model.c \
+ gal-view-collection.c \
+ gal-view-etable.c \
+ gal-view-factory-etable.c \
+ gal-view-factory.c \
+ gal-view-instance-save-as-dialog.c \
+ gal-view-instance.c \
+ gal-view-new-dialog.c \
+ gal-view.c \
+ $(PLATFORM_SOURCES) \
+ $(NULL)
libeutil_la_LDFLAGS = -avoid-version $(NO_UNDEFINED)
-libeutil_la_LIBADD = \
- $(top_builddir)/libevolution-utils/libevolution-utils.la \
- $(ICONV_LIBS) \
- $(EVOLUTION_DATA_SERVER_LIBS) \
- $(GNOME_PLATFORM_LIBS) \
- $(INTLLIBS)
+libeutil_la_LIBADD = \
+ $(top_builddir)/libgnomecanvas/libgnomecanvas.la \
+ $(ICONV_LIBS) \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(CHAMPLAIN_LIBS) \
+ $(GEO_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(INTLLIBS) \
+ $(MATH_LIB) \
+ $(NULL)
-error_DATA = e-system.error
-errordir = $(privdatadir)/errors
-@EVO_PLUGIN_RULE@
+TEST_CPPFLAGS = \
+ $(libeutil_la_CPPFLAGS) \
+ $(NULL)
+
+TEST_LDADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(libeutil_la_LIBADD) \
+ $(NULL)
+
+evolution_source_viewer_CPPFLAGS = $(TEST_CPPFLAGS)
+evolution_source_viewer_SOURCES = evolution-source-viewer.c
+evolution_source_viewer_LDADD = $(TEST_LDADD)
+
+test_calendar_CPPFLAGS = $(TEST_CPPFLAGS)
+test_calendar_SOURCES = test-calendar.c
+test_calendar_LDADD = $(TEST_LDADD)
+
+test_category_completion_CPPFLAGS = $(TEST_CPPFLAGS)
+test_category_completion_SOURCES = test-category-completion.c
+test_category_completion_LDADD = $(TEST_LDADD)
+
+test_contact_store_CPPFLAGS = $(TEST_CPPFLAGS)
+test_contact_store_SOURCES = test-contact-store.c
+test_contact_store_LDADD = $(TEST_LDADD)
+
+test_dateedit_CPPFLAGS = $(TEST_CPPFLAGS)
+test_dateedit_SOURCES = test-dateedit.c
+test_dateedit_LDADD = $(TEST_LDADD)
+
+test_mail_signatures_CPPFLAGS = $(TEST_CPPFLAGS)
+test_mail_signatures_SOURCES = test-mail-signatures.c
+test_mail_signatures_LDADD = $(TEST_LDADD)
+
+test_name_selector_CPPFLAGS = $(TEST_CPPFLAGS)
+test_name_selector_SOURCES = test-name-selector.c
+test_name_selector_LDADD = $(TEST_LDADD)
+
+test_preferences_window_CPPFLAGS = $(TEST_CPPFLAGS)
+test_preferences_window_SOURCES = test-preferences-window.c
+test_preferences_window_LDADD = $(TEST_LDADD)
+
+test_source_combo_box_CPPFLAGS = $(TEST_CPPFLAGS)
+test_source_combo_box_SOURCES = test-source-combo-box.c
+test_source_combo_box_LDADD = $(TEST_LDADD)
+
+test_source_config_CPPFLAGS = $(TEST_CPPFLAGS)
+test_source_config_SOURCES = test-source-config.c
+test_source_config_LDADD = $(TEST_LDADD)
+
+test_source_selector_CPPFLAGS = $(TEST_CPPFLAGS)
+test_source_selector_SOURCES = test-source-selector.c
+test_source_selector_LDADD = $(TEST_LDADD)
+
+EXTRA_DIST = \
+ e-util-enumtypes.h.template \
+ e-util-enumtypes.c.template \
+ e-system.error.xml \
+ filter.error.xml \
+ widgets.error.xml \
+ e-marshal.list \
+ $(ui_DATA)
+ $(NULL)
-EXTRA_DIST = \
- e-util-enumtypes.h.template \
- e-util-enumtypes.c.template \
- e-system.error.xml \
- e-marshal.list
+BUILT_SOURCES = \
+ $(ENUM_GENERATED) \
+ $(MARSHAL_GENERATED) \
+ $(error_DATA) \
+ $(NULL)
-BUILT_SOURCES = $(ENUM_GENERATED) $(MARSHAL_GENERATED) $(error_DATA)
-CLEANFILES = $(BUILT_SOURCES)
+CLEANFILES = $(BUILT_SOURCES)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)