aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:01:40 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:01:40 +0800
commit48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c (patch)
tree6093997da65261322aeca479a2df25652c69c5a9 /e-util/Makefile.am
parent24112a277959156d8ad8d99cfa8b11a43fdd6db0 (diff)
downloadgsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar.gz
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar.bz2
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar.lz
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar.xz
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.tar.zst
gsoc2013-evolution-48c9c3dc71e7381fdabdefaddc29fd9b44fa0b6c.zip
(libeutil_static_la_DEPENDENCIES): Make
libeutil-static.la depend on libeutil.la so that parallel compilations work; building them at the same time confuses libtool. (e-util-marshal.h, e-util-marshal.c): Use different tmp files so these rules can happen in parallel. svn path=/trunk/; revision=19871
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index f9ab2c9e55..a408c331ee 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -87,14 +87,14 @@ libeutil_la_SOURCES = \
# GLib marshalling cruft
e-util-marshal.h: e-util-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --header > e-util-marshal.tmp \
- && mv e-util-marshal.tmp e-util-marshal.h ) \
- || ( rm -f e-util-marshal.tmp && exit 1 )
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --header > e-util-marshal.h.tmp \
+ && mv e-util-marshal.h.tmp e-util-marshal.h ) \
+ || ( rm -f e-util-marshal.h.tmp && exit 1 )
e-util-marshal.c: e-util-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --body > e-util-marshal.tmp \
- && mv e-util-marshal.tmp e-util-marshal.c ) \
- || ( rm -f e-util-marshal.tmp && exit 1 )
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --body > e-util-marshal.c.tmp \
+ && mv e-util-marshal.c.tmp e-util-marshal.c ) \
+ || ( rm -f e-util-marshal.c.tmp && exit 1 )
MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
@@ -108,6 +108,9 @@ libeutil_la_LIBADD = $(E_UTIL_LIBS)
libeutil_static_la_SOURCES = $(libeutil_la_SOURCES)
libeutil_static_la_LIBADD = $(libeutil_la_LIBADD)
libeutil_static_la_LDFLAGS = -all-static
+# Make sure libeutil.la and libeutil-static.la are not built in
+# parallel when using a parallel make; libtool can't handle that.
+libeutil_static_la_DEPENDENCIES = libeutil.la
econdinclude_HEADERS = \
e-pilot-map.h \