aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorKaushal Kumar <kakumar@novell.com>2005-06-17 23:20:35 +0800
committerKaushal Kumar <kaushal@src.gnome.org>2005-06-17 23:20:35 +0800
commit27a61acf278caf11e5e203d4ee13e107d5b84b2d (patch)
tree3cfc4a916ecfd4d75587e6939b4e4990a35eb5d1 /e-util/Makefile.am
parent5a7ddf3c6dab1474185d7c92a1413601878eb690 (diff)
downloadgsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.gz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.bz2
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.lz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.xz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.zst
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.zip
Retired GAL from Head. The relevant files have moved inside evolution.
2005-06-17 Kaushal Kumar <kakumar@novell.com> * Retired GAL from Head. The relevant files have moved inside evolution. Thanks to JP Rosevear for performing the cvs surgery. The files have been moved in the following order. evolution/e-util <- gal/gal/util evolution/a11y <- gal/gal/a11y evolution/a11y/e-table <- gal/gal/a11y/e-table evolution/a11y/e-text <- gal/gal/a11y/e-text evolution/widgets/table <- gal/gal/e-table evolution/widgets/text <- gal/gal/e-text evolution/widgets/misc <- gal/gal/widgets evolution/widgets/misc/pixmaps <- gal/gal/widgets/pixmaps evolution/widgets/menus <- gal/gal/menus Following is the summary of changes done to fix the build:- - New files added to cvs repository, - a11y/e-table/Makefile.am - a11y/e-text/Makefile.am - widgets/table/Makefile.am - widgets/text/Makefile.am - widgets/misc/pixmaps/Makefile.am - iconv-detect.h - iconv-detect.c - Updated configure.in. - Updated all the relevant Makefile.am files. - Updated the include paths to replace all gal references. - Updated the marshal list to suit gal files requirements. svn path=/trunk/; revision=29522
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am38
1 files changed, 34 insertions, 4 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 2dbd2d7962..599f93a051 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -1,15 +1,27 @@
eutilincludedir = $(privincludedir)/e-util
econdincludedir = $(privincludedir)/e-conduit
+if OS_WIN32
+PLATFORM_SOURCES = e-win32-reloc.c
+endif
+
INCLUDES = \
-I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DEVOLUTION_PREFIX=\""$(prefix)"\" \
-DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
-DEVOLUTION_ICONSDIR=\""$(imagesdir)"\" \
-DEVOLUTION_CATEGORY_ICONS=\""$(imagesdir)/categories"\" \
-DEVOLUTION_PLUGINDIR=\""$(plugindir)"\" \
-DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DGAL_IMAGESDIR=\""$(imagesdir)"\" \
-DG_LOG_DOMAIN=\"e-utils\" \
$(GNOME_PILOT_CFLAGS) \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(GNOME_FULL_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ $(ICONV_CFLAGS) \
$(E_UTIL_CFLAGS)
privlib_LTLIBRARIES = libeutil.la libeconduit.la
@@ -19,7 +31,6 @@ eutilinclude_HEADERS = \
e-account.h \
e-bconf-map.h \
e-categories-config.h \
- e-categories-master-list-wombat.h \
e-component-listener.h \
e-config.h \
e-config-listener.h \
@@ -50,7 +61,16 @@ eutilinclude_HEADERS = \
e-signature-list.h \
e-time-utils.h \
e-uid.h \
- md5-utils.h
+ md5-utils.h \
+ e-bit-array.h \
+ e-iconv.h \
+ e-sorter.h \
+ e-sorter-array.h \
+ e-text-event-processor-emacs-like.h \
+ e-text-event-processor-types.h \
+ e-text-event-processor.h \
+ e-util.h \
+ e-xml-utils.h
libeutil_la_SOURCES = \
$(MARSHAL_GENERATED) \
@@ -59,7 +79,6 @@ libeutil_la_SOURCES = \
e-account.c \
e-bconf-map.c \
e-categories-config.c \
- e-categories-master-list-wombat.c \
e-component-listener.c \
e-config.c \
e-config-listener.c \
@@ -92,7 +111,18 @@ libeutil_la_SOURCES = \
e-uid.c \
eggtrayicon.c \
eggtrayicon.h \
- md5-utils.c
+ md5-utils.c \
+ e-bit-array.c \
+ e-i18n.h \
+ e-iconv.c \
+ e-sorter.c \
+ e-sorter-array.c \
+ e-text-event-processor-emacs-like.c \
+ e-text-event-processor.c \
+ e-util.c \
+ e-util-private.h \
+ e-xml-utils.c \
+ $(PLATFORM_SOURCES)
MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
@EVO_MARSHAL_RULE@