aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-03 13:46:46 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-03 13:46:46 +0800
commit805e75e7d9315f8cb9f6a7213fc373a8a873a242 (patch)
treedd0063aea1ff40a14325ec4021cd3f69abe7fc20 /e-util/Makefile.am
parent9c73777f2268b5bf2622f893e2a3ba7d0f720572 (diff)
downloadgsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar.gz
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar.bz2
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar.lz
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar.xz
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.tar.zst
gsoc2013-evolution-805e75e7d9315f8cb9f6a7213fc373a8a873a242.zip
add marshal building stuff, add e-util-marshal.c to SOURCES, and add
2002-11-02 Chris Toshok <toshok@ximian.com> * Makefile.am: add marshal building stuff, add e-util-marshal.c to SOURCES, and add e-util-marshal.list to EXTRA_DIST. * e-util-marshal.list: add marshallers for e-util. * e-list.c: convert to GObject. * e-list.h: convert to GObject. * e-iterator.c: convert to GObject. * e-iterator.h: convert to GObject. * e-list-iterator.c: convert to GObject. * e-list-iterator.h: convert to GObject. * .cvsignore: ignore e-util-marshal.[ch] svn path=/trunk/; revision=18504
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 19ff7b0e53..39a27e9c7d 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -59,8 +59,24 @@ libeutil_la_SOURCES = \
e-sexp.c \
e-time-utils.c \
e-url.c \
+ e-util-marshal.c \
md5-utils.c
+# GLib marshalling cruft
+
+e-util-marshal.h: e-util-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --header > e-util-marshal.tmp \
+ && mv e-util-marshal.tmp e-util-marshal.h ) \
+ || ( rm -f e-util-marshal.tmp && exit 1 )
+
+e-util-marshal.c: e-util-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --body > e-util-marshal.tmp \
+ && mv e-util-marshal.tmp e-util-marshal.c ) \
+ || ( rm -f e-util-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
+
+
# FIXME TODO
# e-categories-config.c
# e-categories-master-list-wombat.[ch]
@@ -99,7 +115,7 @@ libeconduit_la_SOURCES = $(pilot_compile)
libeconduit_static_la_SOURCES = $(libeconduit_la_SOURCES)
libeconduit_static_la_LDFLAGS = -all-static
-EXTRA_DIST = $(pilot_sources)
+EXTRA_DIST = $(pilot_sources) e-util-marshal.list
edb3include_HEADERS = \
e-db3-utils.h \
@@ -109,3 +125,6 @@ libedb3util_la_SOURCES = \
$(edb3include_HEADERS) \
e-db3-utils.c \
e-dbhash.c
+
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)