aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authornobody <nobody@localhost>2002-12-28 12:49:29 +0800
committernobody <nobody@localhost>2002-12-28 12:49:29 +0800
commitab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9 (patch)
tree1e12040caec266ee2e16460c80583d4af3687d10 /e-util/Makefile.am
parent79d8fd91171f81a97c319616dcca32002269af55 (diff)
downloadgsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar.gz
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar.bz2
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar.lz
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar.xz
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.tar.zst
gsoc2013-evolution-ab7d6ef097bf18a3ebb97c4d73947fe8d2f059c9.zip
This commit was manufactured by cvs2svn to create tag 'GHEX_2_0_0'.GHEX_2_0_0
svn path=/tags/GHEX_2_0_0/; revision=19188
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am137
1 files changed, 0 insertions, 137 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
deleted file mode 100644
index 986bccf5e7..0000000000
--- a/e-util/Makefile.am
+++ /dev/null
@@ -1,137 +0,0 @@
-SUBDIRS = . ename
-
-imagesdir = $(datadir)/images/evolution
-
-eutilincludedir = $(includedir)/evolution/e-util
-econdincludedir = $(includedir)/evolution/e-conduit
-edb3includedir = $(includedir)/evolution/e-db3util
-
-INCLUDES = \
- -I$(top_srcdir) \
- -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
- -DEVOLUTION_CATEGORY_ICONS=\""$(imagesdir)/categories"\" \
- -DG_LOG_DOMAIN=\"e-utils\" \
- $(DB3_CFLAGS) \
- $(PISOCK_CFLAGS) \
- $(E_UTIL_CFLAGS)
-
-privlib_LTLIBRARIES = libeutil.la libedb3util.la libeconduit.la
-noinst_LTLIBRARIES = libeutil-static.la libeconduit-static.la
-
-eutilinclude_HEADERS = \
- e-categories-config.h \
- e-categories-master-list-wombat.h \
- e-component-listener.h \
- e-config-listener.h \
- e-corba-utils.h \
- e-dialog-widgets.h \
- e-gtk-utils.h \
- e-gui-utils.h \
- e-host-utils.h \
- e-iterator.h \
- e-lang-utils.h \
- e-list-iterator.h \
- e-list.h \
- e-memory.h \
- e-mktemp.h \
- e-msgport.h \
- e-passwords.h \
- e-path.h \
- e-proxy.h \
- e-request.h \
- e-sexp.h \
- e-time-utils.h \
- e-trie.h \
- e-url.h \
- md5-utils.h
-
-libeutil_la_SOURCES = \
- $(eutilinclude_HEADERS) \
- e-categories-config.c \
- e-categories-master-list-wombat.c \
- e-component-listener.c \
- e-config-listener.c \
- e-corba-utils.c \
- e-dialog-utils.c \
- e-dialog-widgets.c \
- e-gtk-utils.c \
- e-gui-utils.c \
- e-host-utils.c \
- e-iterator.c \
- e-lang-utils.c \
- e-list-iterator.c \
- e-list.c \
- e-memory.c \
- e-mktemp.c \
- e-msgport.c \
- e-passwords.c \
- e-path.c \
- e-proxy.c \
- e-request.c \
- e-sexp.c \
- e-time-utils.c \
- e-trie.c \
- e-url.c \
- e-util-marshal.c \
- md5-utils.c
-
-# GLib marshalling cruft
-
-e-util-marshal.h: e-util-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --header > e-util-marshal.tmp \
- && mv e-util-marshal.tmp e-util-marshal.h ) \
- || ( rm -f e-util-marshal.tmp && exit 1 )
-
-e-util-marshal.c: e-util-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --body > e-util-marshal.tmp \
- && mv e-util-marshal.tmp e-util-marshal.c ) \
- || ( rm -f e-util-marshal.tmp && exit 1 )
-
-MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
-
-
-# FIXME TODO
-# e-passwords.c
-# bonobo-factory-util.[ch]
-
-libeutil_la_LIBADD = $(E_UTIL_LIBS)
-
-libeutil_static_la_SOURCES = $(libeutil_la_SOURCES)
-libeutil_static_la_LIBADD = $(libeutil_la_LIBADD)
-libeutil_static_la_LDFLAGS = -all-static
-
-econdinclude_HEADERS = \
- e-pilot-map.h \
- e-pilot-settings.h \
- e-pilot-util.h
-
-pilot_sources = \
- $(econdinclude_HEADERS) \
- e-pilot-map.c \
- e-pilot-settings.c \
- e-pilot-util.c
-
-if ENABLE_PILOT_CONDUITS
-pilot_compile = $(pilot_sources)
-else
-pilot_compile =
-endif
-
-libeconduit_la_SOURCES = $(pilot_compile)
-
-libeconduit_static_la_SOURCES = $(libeconduit_la_SOURCES)
-libeconduit_static_la_LDFLAGS = -all-static
-
-EXTRA_DIST = $(pilot_sources) e-util-marshal.list
-
-edb3include_HEADERS = \
- e-db3-utils.h \
- e-dbhash.h
-
-libedb3util_la_SOURCES = \
- $(edb3include_HEADERS) \
- e-db3-utils.c \
- e-dbhash.c
-
-BUILT_SOURCES = $(MARSHAL_GENERATED)
-CLEANFILES = $(BUILT_SOURCES)