aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-08-05 12:30:33 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-08-05 12:30:33 +0800
commitd682c4f31ee76d09bb11cc06a79aa4522a35f229 (patch)
treea8e90c9fb5fe481e4f771572304465ec95ed78c4 /e-util/Makefile.am
parent324f2b9768e8b30849cea65f640b381f7f7ddfd0 (diff)
downloadgsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar.gz
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar.bz2
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar.lz
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar.xz
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.tar.zst
gsoc2013-evolution-d682c4f31ee76d09bb11cc06a79aa4522a35f229.zip
New function to create a factory that creates separate component instances
* e-bonobo-factory-util.c (e_bonobo_generic_factory_multi_display_new): New function to create a factory that creates separate component instances for different displays. svn path=/trunk/; revision=11686
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am90
1 files changed, 46 insertions, 44 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 73473d26e7..39ca927a5a 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -2,14 +2,14 @@ SUBDIRS = . ename
imagesdir = $(datadir)/images/evolution
-INCLUDES = \
- $(DB3_CFLAGS) \
- -I$(top_srcdir) \
- $(GNOME_INCLUDEDIR) \
- $(EXTRA_GNOME_CFLAGS) \
- $(BONOBO_CONF_CFLAGS) \
- $(PISOCK_CFLAGS) \
- -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
+INCLUDES = \
+ $(DB3_CFLAGS) \
+ -I$(top_srcdir) \
+ $(GNOME_INCLUDEDIR) \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(BONOBO_CONF_CFLAGS) \
+ $(PISOCK_CFLAGS) \
+ -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
-DEVOLUTION_CATEGORY_ICONS=\""$(imagesdir)/categories"\" \
-DG_LOG_DOMAIN=\"e-utils\"
@@ -17,44 +17,46 @@ noinst_LTLIBRARIES = libeutil.la libeutil-static.la \
libeconduit.la libeconduit-static.la \
libedb3util.la
-libeutil_la_SOURCES = \
+libeutil_la_SOURCES = \
+ e-bonobo-factory-util.c \
+ e-bonobo-factory-util.h \
e-categories-master-list-wombat.c \
e-categories-master-list-wombat.h \
- e-categories-config.c \
- e-categories-config.h \
- e-corba-utils.c \
- e-corba-utils.h \
- e-dialog-widgets.c \
- e-dialog-widgets.h \
- e-gtk-utils.c \
- e-gtk-utils.h \
- e-gui-utils.c \
- e-gui-utils.h \
- e-host-utils.c \
- e-host-utils.h \
- e-html-utils.c \
- e-html-utils.h \
- e-iterator.c \
- e-iterator.h \
- e-list-iterator.c \
- e-list-iterator.h \
- e-list.c \
- e-list.h \
- e-memory.c \
- e-memory.h \
- e-msgport.c \
- e-msgport.h \
- e-path.c \
- e-path.h \
- e-request.c \
- e-request.h \
- e-sexp.c \
- e-sexp.h \
- e-time-utils.c \
- e-time-utils.h \
- e-url.c \
- e-url.h \
- md5-utils.c \
+ e-categories-config.c \
+ e-categories-config.h \
+ e-corba-utils.c \
+ e-corba-utils.h \
+ e-dialog-widgets.c \
+ e-dialog-widgets.h \
+ e-gtk-utils.c \
+ e-gtk-utils.h \
+ e-gui-utils.c \
+ e-gui-utils.h \
+ e-host-utils.c \
+ e-host-utils.h \
+ e-html-utils.c \
+ e-html-utils.h \
+ e-iterator.c \
+ e-iterator.h \
+ e-list-iterator.c \
+ e-list-iterator.h \
+ e-list.c \
+ e-list.h \
+ e-memory.c \
+ e-memory.h \
+ e-msgport.c \
+ e-msgport.h \
+ e-path.c \
+ e-path.h \
+ e-request.c \
+ e-request.h \
+ e-sexp.c \
+ e-sexp.h \
+ e-time-utils.c \
+ e-time-utils.h \
+ e-url.c \
+ e-url.h \
+ md5-utils.c \
md5-utils.h
libeutil_la_LIBADD = $(GAL_LIBS)