aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/evolution-shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-05-27 03:41:29 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-05-28 21:56:30 +0800
commit70a9fcdf9c61c09fcac72ddf99e73cb57ed99017 (patch)
tree1fa36e300d0d126e889416f807bf7b09018bc63a /doc/reference/evolution-shell/Makefile.am
parent6c9a3243c9b335cb7e5873b15562263e74293dc2 (diff)
downloadgsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar.gz
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar.bz2
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar.lz
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar.xz
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.tar.zst
gsoc2013-evolution-70a9fcdf9c61c09fcac72ddf99e73cb57ed99017.zip
Rename libeshell to libevolution-shell.
To make Evolution's shared libraries more consistent. Also rename the documentation module to evolution-shell.
Diffstat (limited to 'doc/reference/evolution-shell/Makefile.am')
-rw-r--r--doc/reference/evolution-shell/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/doc/reference/evolution-shell/Makefile.am b/doc/reference/evolution-shell/Makefile.am
new file mode 100644
index 0000000000..5ff5a0af32
--- /dev/null
+++ b/doc/reference/evolution-shell/Makefile.am
@@ -0,0 +1,43 @@
+# The name of the module.
+DOC_MODULE=evolution-shell
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+DOC_SOURCE_DIR=$(top_srcdir)/shell
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB=$(top_srcdir)/shell/*.h
+CFILE_GLOB=$(top_srcdir)/shell/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES= \
+ evo-version.h \
+ e-shell-window-private.h \
+ es-event.h \
+ $(NULL)
+
+GTKDOC_CFLAGS= \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS= \
+ $(top_builddir)/libemail-engine/libemail-engine.la \
+ $(top_builddir)/shell/libevolution-shell.la \
+ $(top_builddir)/e-util/libevolution-util.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk