aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/evolution-mail-formatter/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-05-27 04:18:25 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-05-28 21:56:30 +0800
commit04aa0fba1f96cac50e8006e7dd806cf042138851 (patch)
treed7a73b8679f3fe17ae1c446c3c60e27e5bf8a01e /doc/reference/evolution-mail-formatter/Makefile.am
parent70a9fcdf9c61c09fcac72ddf99e73cb57ed99017 (diff)
downloadgsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar.gz
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar.bz2
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar.lz
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar.xz
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.tar.zst
gsoc2013-evolution-04aa0fba1f96cac50e8006e7dd806cf042138851.zip
Rename libemformat to libevolution-mail-formatter.
To make Evolution's shared libraries more consistent. Also add an evolution-mail-formatter documentation module.
Diffstat (limited to 'doc/reference/evolution-mail-formatter/Makefile.am')
-rw-r--r--doc/reference/evolution-mail-formatter/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/doc/reference/evolution-mail-formatter/Makefile.am b/doc/reference/evolution-mail-formatter/Makefile.am
new file mode 100644
index 0000000000..1584f84355
--- /dev/null
+++ b/doc/reference/evolution-mail-formatter/Makefile.am
@@ -0,0 +1,38 @@
+# The name of the module.
+DOC_MODULE=evolution-mail-formatter
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+DOC_SOURCE_DIR=$(top_srcdir)/em-format
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB=$(top_srcdir)/em-format/*.h
+CFILE_GLOB=$(top_srcdir)/em-format/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES= \
+ $(NULL)
+
+GTKDOC_CFLAGS= \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS= \
+ $(top_builddir)/em-format/libevolution-mail-formatter.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk