aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/evolution-mail-engine/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-11-10 22:55:30 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-11-11 21:10:10 +0800
commita7b322d37eb2f2db2e62411eddcc76bd564493d8 (patch)
treed91650e66199589654dd55de87f386d21e67bec7 /doc/reference/evolution-mail-engine/Makefile.am
parent7a488efbb38b623b9c9658ed4350d7e263a89d71 (diff)
downloadgsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar.gz
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar.bz2
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar.lz
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar.xz
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.tar.zst
gsoc2013-evolution-a7b322d37eb2f2db2e62411eddcc76bd564493d8.zip
Generate documentation for libemail-engine.
Diffstat (limited to 'doc/reference/evolution-mail-engine/Makefile.am')
-rw-r--r--doc/reference/evolution-mail-engine/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/doc/reference/evolution-mail-engine/Makefile.am b/doc/reference/evolution-mail-engine/Makefile.am
new file mode 100644
index 0000000000..91b077f4ed
--- /dev/null
+++ b/doc/reference/evolution-mail-engine/Makefile.am
@@ -0,0 +1,39 @@
+# The name of the module.
+DOC_MODULE=evolution-mail-engine
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+DOC_SOURCE_DIR=$(top_srcdir)/libemail-engine
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB=$(top_srcdir)/libemail-engine/*.h
+CFILE_GLOB=$(top_srcdir)/libemail-engine/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES= \
+ e-mail-enumtypes.h \
+ $(NULL)
+
+GTKDOC_CFLAGS= \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS= \
+ $(top_builddir)/libemail-engine/libemail-engine.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk