aboutsummaryrefslogtreecommitdiffstats
path: root/doc/devel/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2001-06-22 03:19:42 +0800
committerPeter Williams <peterw@src.gnome.org>2001-06-22 03:19:42 +0800
commitc2f24a98ce703b3dba475989f152ada24b68bc0f (patch)
tree3311910754571fd0e9d216cd6cbf5005dfc44907 /doc/devel/Makefile.am
parente061c100c7ef9d316a33bfb537022d5b8b307389 (diff)
downloadgsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar.gz
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar.bz2
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar.lz
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar.xz
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.tar.zst
gsoc2013-evolution-c2f24a98ce703b3dba475989f152ada24b68bc0f.zip
calendar/cal-client/Makefile.am: calendar/cal-util/Makefile.am:
2001-06-21 Peter Williams <peterw@ximian.com> * Makefile.am: calendar/cal-client/Makefile.am: calendar/cal-util/Makefile.am: importer/Makefile.am: executive-summary/Makefile.am: Changed to used gtk-doc's canonical Makefile.am (plus some tweaks because not every dir builds html). svn path=/trunk/; revision=10375
Diffstat (limited to 'doc/devel/Makefile.am')
-rw-r--r--doc/devel/Makefile.am141
1 files changed, 115 insertions, 26 deletions
diff --git a/doc/devel/Makefile.am b/doc/devel/Makefile.am
index 200905cffe..a832b8ea22 100644
--- a/doc/devel/Makefile.am
+++ b/doc/devel/Makefile.am
@@ -1,22 +1,37 @@
+## Process this file with automake to produce Makefile.in
+
SUBDIRS = calendar executive-summary
-# The name of the module.
+# The name of the module, e.g. 'glib'.
DOC_MODULE=evolution-devel-guide
-# The top-level SGML file.
+# The top-level SGML file. Change it if you want.
DOC_MAIN_SGML_FILE=evolution-devel-guide.sgml
-HTML_DIR=$(datadir)/gnome/html
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting functions and macros.
+#DOC_SOURCE_DIR=
-TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+# Extra options to supply to gtkdoc-scan.
+#SCAN_OPTIONS=
-# Add your toplevel files here
+# Extra options to supply to gtkdoc-mkdb.
+#MKDB_OPTIONS=
+
+# Extra options to supply to gtkdoc-fixref.
+#FIXXREF_OPTIONS=
+
+# Used for dependencies.
+#HFILE_GLOB=
+#CFILE_GLOB=
+
+# Header files to ignore when scanning.
+#IGNORE_HFILES=
+
+# Images to copy into HTML directory.
+HTML_IMAGES =
-content_files = \
- evolution-devel-guide.sgml \
- fdl.sgml \
- preface.sgml \
- reference.sgml
# Add your module's hand-written and auto-generated files here; these
# are used for dependency tracking.
@@ -42,26 +57,78 @@ local_entities = \
# importer/sgml/evolution-importer.sgml \
# importer/sgml/evolution-importer-client.sgml
-EXTRA_DIST = \
- $(content_files)
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files = \
+ evolution-devel-guide.sgml \
+ fdl.sgml \
+ preface.sgml \
+ reference.sgml \
+ $(local_entities)
+
+# Other files to distribute.
+extra_files =
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
+# contains GtkObjects/GObjects and you want to document signals and properties.
+#GTKDOC_CFLAGS =
+#GTKDOC_LIBS =
+#
+#GTKDOC_CC=$(LIBTOOL) --mode=compile $(CC)
+#GTKDOC_LD=$(LIBTOOL) --mode=link $(CC)
+
+# If you need to override some of the declarations, place them in this file
+# and uncomment this line.
+#DOC_OVERRIDES = $(DOC_MODULE)-overrides.txt
+
+HTML_DIR = $(datadir)/gnome/html
-all: html/index.html
+###########################################################################
+# Everything below here is generic and you shouldn't need to change it.
+###########################################################################
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+EXTRA_DIST = \
+ $(content_files) \
+ $(extra_files) \
+ $(HTML_IMAGES) \
+ $(DOC_MAIN_SGML_FILE)
+
+# $(DOC_MODULE).types \
+# $(DOC_MODULE)-sections.txt \
+# $(DOC_OVERRIDES)
+
+DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
+ $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
+
+#SCANOBJ_FILES = \
+# $(DOC_MODULE).args \
+# $(DOC_MODULE).hierarchy \
+# $(DOC_MODULE).signals
if ENABLE_GTK_DOC
-html/index.html: $(content_files) $(local_entities)
+all-local: html-build.stamp
+
+#### html ####
+
+html-build.stamp: $(DOC_MAIN_SGML_FILE) $(content_files) #sgml.stamp
+ @echo '*** Building HTML ***'
test -d $(srcdir)/html || mkdir $(srcdir)/html
- -cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
-else
-html/index.html:
+ cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+ test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
+ @echo '-- Fixing Crossreferences'
+ cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
+ touch html-build.stamp
endif
+##############
+
clean-local:
- rm -f *~ *.bak *.signals *-unused.txt
+ rm -f *~ *.bak *-unused.txt $(DOC_STAMPS) # $(SCANOBJ_FILES)
-maintainer-clean-local:
- cd $(srcdir) && rm -rf html
+maintainer-clean-local: clean
+ cd $(srcdir) && rm -rf sgml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
-if ENABLE_GTK_DOC
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(TARGET_DIR)
(installfiles=`echo $(srcdir)/html/*.html`; \
@@ -72,13 +139,35 @@ install-data-local:
echo '-- Installing '$$i ; \
$(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
done; \
- echo '-- Installing $(srcdir)/html/index.sgml' ; \
- $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
- echo '-- Fixing Crossreferences' ; \
- gtkdoc-fixxref --module=$(DOC_MODULE) --html-dir=$(HTML_DIR)|| true; \
fi)
+
+# echo '-- Installing $(srcdir)/html/index.sgml' ; \
+# $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
+
+#
+# Require gtk-doc when making dist
+#
+if ENABLE_GTK_DOC
+dist-check-gtkdoc:
+else
+dist-check-gtkdoc:
+ @echo "*** gtk-doc must be installed and enabled in order to make dist"
+ @false
endif
-dist-hook:
+dist-hook: dist-check-gtkdoc dist-hook-local
mkdir $(distdir)/html
+ -cp $(srcdir)/html/index.sgml $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
+
+ images=$(HTML_IMAGES) ; \
+ for i in $$images ; do \
+ cp $(srcdir)/$$i $(distdir)/html ; \
+ done
+
+# mkdir $(distdir)/tmpl
+# mkdir $(distdir)/sgml
+# -cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
+# -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+
+.PHONY : dist-hook-local