aboutsummaryrefslogtreecommitdiffstats
path: root/doc/devel/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-11-30 00:26:59 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-11-30 00:26:59 +0800
commitef585975d00ddbc021fa9a1181723c67b3223a82 (patch)
tree74bf29327f90e2c166ee7a763ca632ba061bd894 /doc/devel/Makefile.am
parent6b07a364e2dd3ce534b58a2056248299be8b54d6 (diff)
downloadgsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar.gz
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar.bz2
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar.lz
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar.xz
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.tar.zst
gsoc2013-evolution-ef585975d00ddbc021fa9a1181723c67b3223a82.zip
Added an id for the API reference <part>. Added the FDL <legalnotice>.
2000-11-29 Federico Mena Quintero <federico@helixcode.com> * evolution-devel-guide.sgml: Added an id for the API reference <part>. Added the FDL <legalnotice>. Added the preface and toplevel reference entities. Added entities for Evolution, Wombat, and Camel. Added an appendix for the GNU FDL. * preface.sgml: New file with the introduction to the Evolution Developer's Guide. * reference.sgml: Split the toplevel reference part into its own file. * fdl.sgml: Added the GNU Free Documentation License. * calendar/evolution-calendar.sgml: Added an id for the <part>. * calendar/public-reference.sgml: Added an id for the <reference>. Moved this file over from calendar/reference.sgml. * Makefile.am (local_entities): Added a list of the SGML files that define entities for inclusion in the toplevel document. This way we can track documentation file dependencies down to all levels. (html/index.html): Made the toplevel document depend on $(local_entities). Also, removed the "html" target and put its contents directly here; this way we avoid having .PHONY targets. (EXTRA_DIST): Removed the evolution_devel_guideDATA; it made no sense. (content_files): Added preface.sgml and reference.sgml. svn path=/trunk/; revision=6715
Diffstat (limited to 'doc/devel/Makefile.am')
-rw-r--r--doc/devel/Makefile.am42
1 files changed, 27 insertions, 15 deletions
diff --git a/doc/devel/Makefile.am b/doc/devel/Makefile.am
index 0d3cec5a1c..0dd533057e 100644
--- a/doc/devel/Makefile.am
+++ b/doc/devel/Makefile.am
@@ -10,28 +10,42 @@ HTML_DIR=$(datadir)/gnome/html
TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
-evolution_devel_guidedir = $(HTML_DIR)
-evolution_devel_guide_DATA = \
- evolution-devel-guide.html
+# Add your toplevel files here
-content_files = \
- evolution-devel-guide.sgml
+content_files = \
+ evolution-devel-guide.sgml \
+ fdl.sgml \
+ preface.sgml \
+ reference.sgml
-EXTRA_DIST = \
- $(evolution_devel_guide_DATA) \
+# Add your module's hand-written and auto-generated files here; these
+# are used for dependency tracking.
+
+local_entities = \
+ calendar/architecture.sgml \
+ calendar/evolution-calendar.sgml \
+ calendar/public-reference.sgml \
+ \
+ calendar/cal-client/sgml/cal-client.sgml \
+ \
+ calendar/cal-util/sgml/cal-component.sgml \
+ calendar/cal-util/sgml/cal-recur.sgml \
+ calendar/cal-util/sgml/cal-util.sgml \
+ calendar/cal-util/sgml/timeutil.sgml
+
+EXTRA_DIST = \
$(content_files)
+all: evolution-devel-guide.html
+
if ENABLE_GTK_DOC
-evolution-devel-guide.html: html/book1.html
- -cd $(srcdir) && cp html/book1.html evolution-devel-guide.html
+evolution-devel-guide.html: html/index.html
+ -cd $(srcdir) && cp html/index.html evolution-devel-guide.html
else
evolution-devel-guide.html:
endif
-html/book1.html: $(content-files)
- $(MAKE) html
-
-html:
+html/index.html: $(content_files) $(local_entities)
test -d $(srcdir)/html || mkdir $(srcdir)/html
-cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
@@ -60,5 +74,3 @@ install-data-local:
dist-hook:
mkdir $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
-
-.PHONY: html