aboutsummaryrefslogtreecommitdiffstats
path: root/doc/devel/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-07-18 05:08:41 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-07-18 05:08:41 +0800
commite38c9ea0ed0f14ce563d355a0cea24460df26363 (patch)
treea54e0ce7fc2887466d6c37df39ac478f2aaa2c93 /doc/devel/Makefile.am
parentfab3b8e23e8ded8e8dba0c2300e49914e35d9145 (diff)
downloadgsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.gz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.bz2
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.lz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.xz
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.tar.zst
gsoc2013-evolution-e38c9ea0ed0f14ce563d355a0cea24460df26363.zip
New <book> toplevel for the Evolution Developer's Guide.
2000-07-17 Federico Mena Quintero <federico@helixcode.com> * evolution-devel-guide.sgml: New <book> toplevel for the Evolution Developer's Guide. * calendar/evolution-calendar.sgml: New <part> for the calendar developer's documentation. * calendar/architecture.sgml: New <chapter> for the calendar architecture. * calendar/reference.sgml: New <reference> for the calendar API reference. svn path=/trunk/; revision=4191
Diffstat (limited to 'doc/devel/Makefile.am')
-rw-r--r--doc/devel/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/doc/devel/Makefile.am b/doc/devel/Makefile.am
new file mode 100644
index 0000000000..63f190c190
--- /dev/null
+++ b/doc/devel/Makefile.am
@@ -0,0 +1,64 @@
+SUBDIRS = calendar
+
+# The name of the module.
+DOC_MODULE=evolution-devel-guide
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=evolution-devel-guide.sgml
+
+HTML_DIR=$(datadir)/gnome/html
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+evolution_devel_guidedir = $(HTML_DIR)
+evolution_devel_guide_DATA = \
+ evolution-devel-guide.html
+
+content_files = \
+ evolution-devel-guide.sgml
+
+EXTRA_DIST = \
+ $(evolution_devel_guide_DATA) \
+ $(content_files)
+
+if ENABLE_GTK_DOC
+evolution-devel-guide.html: html/book1.html
+ -cd $(srcdir) && cp html/book1.html evolution-devel-guide.html
+else
+evolution-devel-guide.html:
+endif
+
+html/book1.html: $(content-files)
+ $(MAKE) html
+
+html:
+ test -d $(srcdir)/html || mkdir $(srcdir)/html
+ -cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+
+clean-local:
+ rm -f *~ *.bak *.signals *-unused.txt
+
+maintainer-clean-local: clean
+ cd $(srcdir) && rm -rf html
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR)
+ (installfiles=`echo $(srcdir)/html/*.html`; \
+ if test "$$installfiles" = '$(srcdir)/html/*.html'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
+ echo '-- Fixing Crossreferences' ; \
+ gtkdoc-fixxref --module=$(DOC_MODULE) --html-dir=$(HTML_DIR)|| true; \
+ fi)
+
+dist-hook:
+ mkdir $(distdir)/html
+ -cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
+
+.PHONY: html