aboutsummaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorMichael Monreal <michael.monreal@gmail.com>2007-10-12 17:49:02 +0800
committerMilan Crha <mcrha@src.gnome.org>2007-10-12 17:49:02 +0800
commit953e66428af9639028b3729b448d1fa01c340d09 (patch)
treed413a2f65852df6fe5fe6eee913378dab774ed23 /data/icons/Makefile.am
parentbe9273d7bab214c49479b4cc96f0a2ffe26ce019 (diff)
downloadgsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.gz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.bz2
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.lz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.xz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.zst
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.zip
** Migration of theme icons to data/icons/ (bug #479257)
2007-10-12 Michael Monreal <michael.monreal@gmail.com> ** Migration of theme icons to data/icons/ (bug #479257) * art/Makefile.am: Remove references to art/$size. * configure.in: Include new data/icons/ directory. * file e-util/e-icon-factory.c: Append a private icon directory to the search path. New inbox/outbox/sent icons. * mail/em-folder-tree.c, mail/mail-send-recv.c: Change icon references. New view-calendar icons. * calendar/gui/calendar-commands.c: Change icon references. svn path=/trunk/; revision=34383
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am119
1 files changed, 119 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000000..b8bca711a8
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,119 @@
+NULL =
+
+public_icons = \
+ hicolor_apps_16x16_evolution.png \
+ hicolor_apps_22x22_evolution.png \
+ hicolor_apps_24x24_evolution.png \
+ hicolor_apps_32x32_evolution.png \
+ hicolor_apps_48x48_evolution.png \
+ hicolor_apps_scalable_evolution.svg \
+ $(NULL)
+
+private_icons = \
+ hicolor_actions_16x16_view-calendar-day.png \
+ hicolor_actions_16x16_view-calendar-list.png \
+ hicolor_actions_16x16_view-calendar-month.png \
+ hicolor_actions_16x16_view-calendar-week.png \
+ hicolor_actions_16x16_view-calendar-workweek.png \
+ hicolor_actions_22x22_view-calendar-day.png \
+ hicolor_actions_22x22_view-calendar-list.png \
+ hicolor_actions_22x22_view-calendar-month.png \
+ hicolor_actions_22x22_view-calendar-week.png \
+ hicolor_actions_22x22_view-calendar-workweek.png \
+ hicolor_actions_24x24_view-calendar-day.png \
+ hicolor_actions_24x24_view-calendar-list.png \
+ hicolor_actions_24x24_view-calendar-month.png \
+ hicolor_actions_24x24_view-calendar-week.png \
+ hicolor_actions_24x24_view-calendar-workweek.png \
+ hicolor_categories_48x48_preferences-autocompletion.png \
+ hicolor_categories_48x48_preferences-calendar-and-tasks.png \
+ hicolor_categories_48x48_preferences-certificates.png \
+ hicolor_categories_48x48_preferences-composer.png \
+ hicolor_categories_48x48_preferences-mail.png \
+ hicolor_categories_48x48_preferences-mail-accounts.png \
+ hicolor_places_16x16_mail-inbox.png \
+ hicolor_places_16x16_mail-outbox.png \
+ hicolor_places_16x16_mail-sent.png \
+ hicolor_places_22x22_mail-inbox.png \
+ hicolor_places_22x22_mail-outbox.png \
+ hicolor_places_22x22_mail-sent.png \
+ hicolor_places_24x24_mail-inbox.png \
+ hicolor_places_24x24_mail-outbox.png \
+ hicolor_places_24x24_mail-sent.png \
+ $(NULL)
+
+noinst_DATA = \
+ hicolor_actions_16x16_view-calendar-day.svg \
+ hicolor_actions_16x16_view-calendar-list.svg \
+ hicolor_actions_16x16_view-calendar-month.svg \
+ hicolor_actions_16x16_view-calendar-week.svg \
+ hicolor_actions_16x16_view-calendar-workweek.svg \
+ hicolor_actions_22x22_view-calendar-day.svg \
+ hicolor_actions_22x22_view-calendar-list.svg \
+ hicolor_actions_22x22_view-calendar-month.svg \
+ hicolor_actions_22x22_view-calendar-week.svg \
+ hicolor_actions_22x22_view-calendar-workweek.svg \
+ hicolor_places_16x16_mail-inbox.svg \
+ hicolor_places_16x16_mail-outbox.svg \
+ hicolor_places_16x16_mail-sent.svg \
+ hicolor_places_22x22_mail-inbox.svg \
+ hicolor_places_22x22_mail-outbox.svg \
+ hicolor_places_22x22_mail-sent.svg \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(public_icons) \
+ $(private_icons) \
+ $(noinst_DATA) \
+ $(NULL)
+
+###############################################################################
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t
+
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache) $(datadir)/icons/hicolor; \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache) $(datadir)/icons/hicolor"; \
+ fi
+
+install-icons:
+ for icon in $(public_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done; \
+ for icon in $(private_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ mkdir -p $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+uninstall-icons:
+ -for icon in $(public_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done; \
+ for icon in $(private_icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ rm -f $(DESTDIR)$(pkgdatadir)/$(BASE_VERSION)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+install-data-local: install-icons update-icon-cache
+
+uninstall-local: uninstall-icons update-icon-cache