aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-09-17 05:01:46 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-09-17 05:01:46 +0800
commitfbc229598cebbe3dc971b91d5302b7bca17e6688 (patch)
tree77393dc1064d61561619eda27e01482d0c97e737 /data/Makefile.am
parentaa526a8c07d7cb2ee018b7b6e6793ecdcb21178a (diff)
downloadgsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.gz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.bz2
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.lz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.xz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.zst
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.zip
New. New. New. New. New. New. New. New. New. New.
* data/cde_app_root/Makefile.am: New. * data/cde_app_root/dt/Makefile.am: New. * data/cde_app_root/dt/appconfig/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/C/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/C/Ximian/Makefile.am: New. * data/cde_app_root/dt/appconfig/icons/Makefile.am: New. * data/cde_app_root/dt/appconfig/icons/C/Makefile.am: New. * data/cde_app_root/dt/appconfig/types/Makefile.am: New. * data/cde_app_root/dt/appconfig/types/C/Makefile.am: New. * configure.in: Add a `--with-cde-path' option. Check for dtappintegrate in that path. Define HAVE_DTAPPINTEGRATE and GNOME_PREFIX. Also, generate data/cde_app_root/dt/appconfig/types/C/Ximian.dt.in and shell/evolution-nognome. svn path=/trunk/; revision=18083
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 20c4dee0cd..20f6d8ca42 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -19,3 +19,19 @@ endif
man_MANS = evolution.1
EXTRA_DIST = $(desktop_in_files) $(keys_in_files) $(mime_DATA) $(man_MANS)
+
+SUBDIRS = cde_app_root
+
+# CDE Stuff
+
+if HAVE_DTAPPINTEGRATE
+
+# This installs Evolution into the Application Manager on CDE
+dtappintegrate:
+ $(DTAPPINTEGRATE) -s $(prefix)/share/evolution/cde_app_root
+
+# ...And this uninstalls it
+dtappunintegrate:
+ $(DTAPPINTEGRATE) -u -s $(prefix)/share/evolution/cde_app_root
+
+endif