aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-08-11 20:30:19 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-08-11 20:36:24 +0800
commit668eeb1ca0b13312a7f7f6a8dd992b49179488c5 (patch)
tree30171442e5c1e06bd5d9df86cb873c25e763d6a6 /data/Makefile.am
parent5265ceb2eddaa87d0d2b63661e94ce37e551dbae (diff)
downloadgsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar.gz
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar.bz2
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar.lz
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar.xz
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.tar.zst
gsoc2013-evolution-668eeb1ca0b13312a7f7f6a8dd992b49179488c5.zip
Fix icon cache updating when building concurrently.
When using "make -j [N > 1]", the install-icons/uninstall-icons and update-icon-cache make targets were running concurrently. Move the icon cache updating to data/Makefile.am to ensure it runs AFTER the icons are installed or uninstalled.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index de1a3d0e39..1bc90ca4af 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -44,6 +44,21 @@ dist_theme_DATA = \
dist_noinst_MANS = evolution.1
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+# Keep the icon cache updating here to ensure the image files
+# under the 'icons' SUBDIR are installed or uninstalled first.
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache) \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
CLEANFILES = \
$(autostart_DATA) \