aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorArturo Espinosa <unammx@src.gnome.org>2000-01-06 13:48:27 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-01-06 13:48:27 +0800
commited4e8afecd5a7f9fab04715ca26a67b2917d78f3 (patch)
treefb33e24ef2eb7c01b225e094d69228c395b1afb4 /configure.in
parent36e5e42d31a56499b1b2534fdf9f6a720b3813e0 (diff)
downloadgsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar.gz
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar.bz2
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar.lz
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar.xz
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.tar.zst
gsoc2013-evolution-ed4e8afecd5a7f9fab04715ca26a67b2917d78f3.zip
Lots of reorganization to get the Evolution shell to begin its life. It
Lots of reorganization to get the Evolution shell to begin its life. It also includes a new evolution widget from Damon. Miguel. svn path=/trunk/; revision=1536
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8129a1a790..6869e4c746 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ AC_CANONICAL_HOST
AM_ACLOCAL_INCLUDE(macros)
GNOME_INIT
-
+GNOME_COMPILE_WARNINGS
AC_ISC_POSIX
AC_PROG_CC
AC_PROG_CPP
@@ -84,11 +84,16 @@ else
AC_MSG_ERROR(Did not find libGlade installed)
fi
-EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui libglade ` `glib-config --libs gthread`"
-EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui libglade ` `glib-config --cflags gthread`"
+EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui libglade `"
+EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui libglade `"
AC_SUBST(EXTRA_GNOME_LIBS)
AC_SUBST(EXTRA_GNOME_CFLAGS)
+EXTRA_GNOME_LIBS_THREADS="`gnome-config --libs gnomeui libglade ` `glib-config --libs gthread`"
+EXTRA_GNOME_CFLAGS_THREADS="`gnome-config --cflags gnomeui libglade ` `glib-config --cflags gthread`"
+AC_SUBST(EXTRA_GNOME_LIBS_THREADS)
+AC_SUBST(EXTRA_GNOME_CFLAGS_THREADS)
+
AC_ARG_WITH(camel-hard-log-level, [ --with-camel-hard-log-level=level value of log level in camel (0-10)],
camel_hard_log_level="$withval", camel_hard_log_level="0")
@@ -98,6 +103,7 @@ AC_OUTPUT([
Makefile
macros/Makefile
po/Makefile.in
+e-util/Makefile
camel/Makefile
camel/providers/Makefile
camel/providers/MH/Makefile
@@ -110,4 +116,7 @@ tests/Makefile
tests/ui-tests/Makefile
widgets/Makefile
widgets/meeting-time-sel/Makefile
+widgets/shortcut-bar/Makefile
+widgets/e-table/Makefile
+shell/Makefile
])