aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-07-18 04:23:34 +0800
committerDan Winship <danw@src.gnome.org>2001-07-18 04:23:34 +0800
commit0e68a67b84f6a3a203c579e70eb153f88be0eccd (patch)
tree84c334108b315b319da21c71c5b02eddc14a90f2 /configure.in
parenta71364b4a1e764bcbc31826bb632c1fa8e06eafb (diff)
downloadgsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar.gz
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar.bz2
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar.lz
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar.xz
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.tar.zst
gsoc2013-evolution-0e68a67b84f6a3a203c579e70eb153f88be0eccd.zip
Fix up the "exactly version N" case of EVO_CHECK_LIB
* configure.in: Fix up the "exactly version N" case of EVO_CHECK_LIB svn path=/trunk/; revision=11169
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ec503f28b7..02fc6555fb 100644
--- a/configure.in
+++ b/configure.in
@@ -32,8 +32,12 @@ AC_DEFUN(EVO_CHECK_LIB, [
ok=yes
if test "$pkgvers" -lt $cmpminvers; then
ok=no
- elif test -n "$maxvers" -a "$pkgvers" -ge $cmpmaxvers; then
- ok=no
+ elif test -n "$maxvers"; then
+ if test "$pkgvers" -gt $cmpmaxvers; then
+ ok=no
+ elif test "$maxvers" != "$minvers" -a "$cmpmaxvers" -eq "$pkgvers"; then
+ ok=no
+ fi
fi
if test $ok = no; then
case $maxvers in