aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-09-17 05:01:46 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-09-17 05:01:46 +0800
commitfbc229598cebbe3dc971b91d5302b7bca17e6688 (patch)
tree77393dc1064d61561619eda27e01482d0c97e737 /configure.in
parentaa526a8c07d7cb2ee018b7b6e6793ecdcb21178a (diff)
downloadgsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.gz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.bz2
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.lz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.xz
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.tar.zst
gsoc2013-evolution-fbc229598cebbe3dc971b91d5302b7bca17e6688.zip
New. New. New. New. New. New. New. New. New. New.
* data/cde_app_root/Makefile.am: New. * data/cde_app_root/dt/Makefile.am: New. * data/cde_app_root/dt/appconfig/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/C/Makefile.am: New. * data/cde_app_root/dt/appconfig/appmanager/C/Ximian/Makefile.am: New. * data/cde_app_root/dt/appconfig/icons/Makefile.am: New. * data/cde_app_root/dt/appconfig/icons/C/Makefile.am: New. * data/cde_app_root/dt/appconfig/types/Makefile.am: New. * data/cde_app_root/dt/appconfig/types/C/Makefile.am: New. * configure.in: Add a `--with-cde-path' option. Check for dtappintegrate in that path. Define HAVE_DTAPPINTEGRATE and GNOME_PREFIX. Also, generate data/cde_app_root/dt/appconfig/types/C/Ximian.dt.in and shell/evolution-nognome. svn path=/trunk/; revision=18083
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8971115f0e..c65a56048f 100644
--- a/configure.in
+++ b/configure.in
@@ -884,6 +884,34 @@ AC_SUBST(NSPR_LDFLAGS)
AC_SUBST(NSS_CFLAGS)
AC_SUBST(NSS_LDFLAGS)
+dnl ******************
+dnl CDE dtappintegrate
+dnl ******************
+
+AC_ARG_WITH(cde-path, [ --with-cde-path=PATH Location of CDE installation],
+ [with_cde_path="$withval"])
+if test -z "$with_cde_path"; then
+ with_cde_path="/usr/dt"
+fi
+
+AC_MSG_CHECKING(for dtappintegrate)
+if test -x "$with_cde_path/bin/dtappintegrate" ; then
+ DTAPPINTEGRATE="$with_cde_path/bin/dtappintegrate"
+else
+ DTAPPINTEGRATE="no"
+fi
+AC_MSG_RESULT([$DTAPPINTEGRATE])
+
+AC_SUBST(DTAPPINTEGRATE)
+AM_CONDITIONAL(HAVE_DTAPPINTEGRATE, test "x$DTAPPINTEGRATE" != "xno")
+
+dnl ****************************************************
+dnl GNOME_PREFIX is is needed by shell/evolution-nognome
+dnl ****************************************************
+
+GNOME_PREFIX="`gnome-config --prefix`"
+AC_SUBST(GNOME_PREFIX)
+
dnl ******************************
dnl OpenSSL
dnl ******************************
@@ -1217,6 +1245,17 @@ camel/tests/smime/Makefile
camel/tests/stream/Makefile
composer/Makefile
data/Makefile
+data/cde_app_root/Makefile
+data/cde_app_root/dt/Makefile
+data/cde_app_root/dt/appconfig/Makefile
+data/cde_app_root/dt/appconfig/appmanager/Makefile
+data/cde_app_root/dt/appconfig/appmanager/C/Makefile
+data/cde_app_root/dt/appconfig/appmanager/C/Ximian/Makefile
+data/cde_app_root/dt/appconfig/icons/Makefile
+data/cde_app_root/dt/appconfig/icons/C/Makefile
+data/cde_app_root/dt/appconfig/types/Makefile
+data/cde_app_root/dt/appconfig/types/C/Makefile
+data/cde_app_root/dt/appconfig/types/C/Ximian.dt
default_user/Makefile
default_user/local/Makefile
default_user/local/Calendar/Makefile
@@ -1249,6 +1288,7 @@ my-evolution/Makefile
omf-install/Makefile
po/Makefile.in
shell/Makefile
+shell/evolution-nognome
shell/glade/Makefile
shell/importer/Makefile
sounds/Makefile