aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-03-21 06:19:01 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-03-21 06:19:01 +0800
commitad0bbfd8a0e705c48b8ed4d7a027426d18f275a3 (patch)
treeebb88743310332a5ce4721fd0e0024022bf14a4f /configure.in
parentef59955e2dbad1fdd14d317283687f8f99fe8117 (diff)
downloadgsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar.gz
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar.bz2
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar.lz
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar.xz
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.tar.zst
gsoc2013-evolution-ad0bbfd8a0e705c48b8ed4d7a027426d18f275a3.zip
More fixes for NSPR and NSS checks - use fixed it to use AC_CHECK_HEADERS
2001-03-20 Jeffrey Stedfast <fejj@ximian.com> * configure.in: More fixes for NSPR and NSS checks - use fixed it to use AC_CHECK_HEADERS instead of AC_CHECK_FILES. Also made it not default the nspr lib path to /usr/lib/mozilla which may not be in the user's library path when checking for nspr libs. svn path=/trunk/; revision=8856
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 24 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 84c19354c4..13fec8c78f 100644
--- a/configure.in
+++ b/configure.in
@@ -603,12 +603,15 @@ AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozill
with_nspr_includes="$withval", with_nspr_includes="/usr/include/mozilla")
have_nspr_includes="no"
if test "x${with_nspr_includes}" != "xno"; then
+ CPPFLAGS_save="$CPPFLAGS"
+
AC_MSG_CHECKING(for Mozilla nspr4 includes in $with_nspr_includes)
AC_MSG_RESULT("")
- HEADERS="$with_nspr_includes/nspr.h $with_nspr_includes/prio.h"
- AC_CHECK_FILES($HEADERS, [ moz_nspr_includes="yes" ])
-
+ CPPFLAGS="$CPPFLAGS -I$with_nspr_includes"
+ AC_CHECK_HEADERS(nspr.h prio.h, [ moz_nspr_includes="yes" ])
+ CPPFLAGS="$CPPFLAGS_save"
+
if test "x{$moz_nspr_includes}" != "xno" -a "x{$moz_nspr_includes}" != "x" ; then
have_nspr_includes="yes"
NSPR_CFLAGS="-I$with_nspr_includes"
@@ -619,7 +622,7 @@ else
fi
AC_ARG_WITH(nspr-libs, [ --with-nspr-libs=PREFIX Location of Mozilla nspr4 libs.],
- with_nspr_libs="$withval", with_nspr_libs="/usr/lib/mozilla")
+ with_nspr_libs="$withval")
have_nspr_libs="no"
if test "x${with_nspr_libs}" != "xno" -a "x${have_nspr_includes}" != "xno"; then
CFLAGS_save="$CFLAGS"
@@ -629,7 +632,13 @@ if test "x${with_nspr_libs}" != "xno" -a "x${have_nspr_includes}" != "xno"; then
AC_CACHE_CHECK([for Mozilla nspr libraries], moz_nspr_libs,
[
CFLAGS="$CFLAGS $NSPR_CFLAGS"
- LDFLAGS="$LDFLAGS -L$with_nspr_libs $nsprlibs"
+
+ if test "x${with_nspr_libs}" != "x"; then
+ LDFLAGS="$LDFLAGS -L$with_nspr_libs $nsprlibs"
+ else
+ LDFLAGS="$LDFLAGS $nsprlibs"
+ fi
+
AC_TRY_LINK_FUNC(PR_Init, moz_nspr_libs="yes", moz_nspr_libs="no")
CFLAGS="$CFLAGS_save"
LDFLAGS="$LDFLAGS_save"
@@ -646,22 +655,24 @@ else
fi
AC_ARG_WITH(nss-includes, [ --with-nss-includes=PREFIX Location of Mozilla nss3 includes.],
- with_nss_includes="$withval", with_nss_includes="no")
+ with_nss_includes="$withval", with_nss_includes="/usr/include/mozilla")
have_nss_includes="no"
if test "x${with_nss_includes}" != "xno" -a "x${have_nspr_libs}" != "xno"; then
+ CPPFLAGS_save="$CPPFLAGS"
+
AC_MSG_CHECKING(for Mozilla nss3 includes in $with_nss_includes)
AC_MSG_RESULT("")
- include_path=$with_nss_includes
- HEADERS="$with_nss_includes/nss.h $with_nss_includes/ssl.h $with_nss_includes/smime.h"
- AC_CHECK_FILES($HEADERS, [ moz_nspr_includes="yes" ])
+ CPPFLAGS="$CPPFLAGS -I$with_nss_includes"
+ AC_CHECK_HEADERS(nss.h ssl.h smime.h, [ moz_nspr_includes="yes" ])
+ CPPFLAGS="$CPPFLAGS_save"
if test "x{$moz_nss_includes}" != "xno" -a "x{$moz_nss_includes}" != "x"; then
have_nss_includes="yes"
NSS_CFLAGS="-I$with_nss_includes"
else
- NSS_CFLAGS=""
- NSS_LDFLAGS=""
+ NSPR_CFLAGS=""
+ NSPR_LDFLAGS=""
fi
else
AC_MSG_CHECKING(for Mozilla nss3 includes)
@@ -669,7 +680,7 @@ else
fi
AC_ARG_WITH(nss-libs, [ --with-nss-libs=PREFIX Location of Mozilla nss3 libs/includes.],
- with_nss_libs="$withval", with_nss_libs="no")
+ with_nss_libs="$withval")
msg_nss="no"
if test "x${with_nss_libs}" != "xno" -a "x${have_nss_includes}" != "xno"; then
LDFLAGS_save="$LDFLAGS"
@@ -687,7 +698,7 @@ if test "x${with_nss_libs}" != "xno" -a "x${have_nss_includes}" != "xno"; then
msg_nss="yes"
NSS_LDFLAGS="-L$with_nss_libs $nsslibs"
else
- NSS_CFAGS=""
+ NSS_CFLAGS=""
NSPR_CFLAGS=""
NSPR_LDFLAGS=""
fi