aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-10-21 06:27:02 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-10-21 06:27:02 +0800
commit51a28ce6a987b81054a438f6d18bad526e1f0f36 (patch)
treefc533b6b1ca3cd2dd015c765a4dd593f69cac6d3 /configure.in
parent752dafc3904e7cb441a1892ae20f6eb1859fe627 (diff)
downloadgsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar.gz
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar.bz2
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar.lz
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar.xz
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.tar.zst
gsoc2013-evolution-51a28ce6a987b81054a438f6d18bad526e1f0f36.zip
Install `evolution.desktop' in the `KDE_APPLNK_DIR'.
* data/Makefile.am [HAVE_KDE_APPLNK]: Install `evolution.desktop' in the `KDE_APPLNK_DIR'. * configure.in: New option `--with-kde-applnk-path'. Define the `HAVE_KDE_APPLNK' Automake conditional, and the `KDE_APPLNK_DIR' value. svn path=/trunk/; revision=13828
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d5f28df685..3d3ed505ba 100644
--- a/configure.in
+++ b/configure.in
@@ -1021,6 +1021,25 @@ dnl ******************
AC_ARG_WITH(sub-version, [ --with-sub-version=VERSION Specify a sub-version string])
AC_DEFINE_UNQUOTED(SUB_VERSION, "$with_sub_version")
+dnl ********************
+dnl KDE applnk directory
+dnl ********************
+AC_ARG_WITH(kde-applnk-path, [ --with-kde-applnk-path=PATH Location of KDE applnk files],
+ [with_kde_applnk_path="$withval"])
+AC_MSG_CHECKING(for the KDE applnk directory)
+if test -z "$with_kde_applnk_path"; then
+ with_kde_applnk_path="$prefix/share/applnk"
+fi
+if test -d "$with_kde_applnk_path" ; then
+ AC_MSG_RESULT("$with_kde_applnk_path" found)
+ KDE_APPLNK_DIR="$with_kde_applnk_path"
+else
+ AC_MSG_RESULT(not found)
+ KDE_APPLNK_DIR="no"
+fi
+AM_CONDITIONAL(HAVE_KDE_APPLNK, test "x$with_kde_applnk_path" != xno)
+AC_SUBST(KDE_APPLNK_DIR)
+
dnl ******************************
dnl Makefiles
dnl ******************************