aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-08-06 00:37:22 +0800
committerDan Winship <danw@src.gnome.org>2000-08-06 00:37:22 +0800
commit51df4b80b2784ddedb81484bafc590ee1df32115 (patch)
tree7775d87c4cc04866a2637f65f5f16c6330b48ff8 /configure.in
parent92e8723c4f2bfafd43ee85d382f1730ca5da7c14 (diff)
downloadgsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar.gz
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar.bz2
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar.lz
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar.xz
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.tar.zst
gsoc2013-evolution-51df4b80b2784ddedb81484bafc590ee1df32115.zip
Update the README and the text of the Bonobo configure check to match
* configure.in, README: Update the README and the text of the Bonobo configure check to match reality. Remove the 0.15 vs 0.15-and-a-half check since we require post-0.16 now. * folder-browser-factory.c (control_activate): Remove bonobo 0.15 vs 0.15-and-a-half ifdef, since we require post-0.16 now. svn path=/trunk/; revision=4552
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 3 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 55f50c0746..0beb68b2c2 100644
--- a/configure.in
+++ b/configure.in
@@ -219,12 +219,12 @@ dnl AC_SUBST(GNOMEGNORBA_LIBS)
dnl ******************************
dnl Check for Bonobo
dnl ******************************
-AC_MSG_CHECKING(for Bonobo >= 0.15)
+AC_MSG_CHECKING(for Bonobo > 0.16)
if gnome-config --libs bonobox > /dev/null 2>&1; then
vers=`gnome-config --modversion bonobo`
case $vers
in
- bonobo-0.?|bonobo-0.1[0-4]) bonobo_ok=false ;;
+ bonobo-0.?|bonobo-0.1[0-5]) bonobo_ok=false ;;
*) bonobo_ok=true ;;
esac
else
@@ -234,25 +234,9 @@ fi
if $bonobo_ok; then
AC_MSG_RESULT($vers found)
else
- AC_MSG_ERROR(Bonobo 0.15 is required to compile Evolution)
+ AC_MSG_ERROR(Bonobo newer than 0.16 is required to compile Evolution)
fi
-dnl Check 0.15 vs post-0.15
-saved_CFLAGS="$CFLAGS"
-saved_LDFLAGS="$LDFLAGS"
-CFLAGS="$CFLAGS `gnome-config --cflags bonobox`"
-LDFLAGS="$LDFLAGS `gnome-config --libs bonobox`"
-AC_TRY_COMPILE([
-#include <bonobo/bonobo-ui-handler.h>
-],[
-bonobo_ui_handler_menu_set_callback (NULL, NULL, NULL, NULL, NULL);
-],bonobo_new=true,bonobo_new=false)
-
-if $bonobo_new; then
- AC_DEFINE(BONOBO_POST_0_15)
-fi
-
-
dnl ******************************
dnl LibGlade checking
dnl ******************************