aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-10-28 04:16:27 +0800
committerDan Winship <danw@src.gnome.org>2001-10-28 04:16:27 +0800
commit9daaceea4e7fd1ca438695a17f59ba18bd345502 (patch)
treef536b2a3e9004d7408a071fe031b7c9a41415e10 /configure.in
parent8c0ef28e5596d18fc960b41b2ff8447c1af6eeb6 (diff)
downloadgsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar.gz
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar.bz2
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar.lz
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar.xz
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.tar.zst
gsoc2013-evolution-9daaceea4e7fd1ca438695a17f59ba18bd345502.zip
Change the help string on "--enable-nntp" to mention the fact that NNTP
* configure.in: Change the help string on "--enable-nntp" to mention the fact that NNTP support is incomplete and unsupported. If the user doesn't pass --enable-nntp, don't mention NNTP at all in the summary at the end. Also, mention which SSL library is being used when SSL support is enabled, and don't mention anything about S/MIME since it doesn't work. svn path=/trunk/; revision=14221
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 13 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 404cd4a4b9..9c0a9d7cf9 100644
--- a/configure.in
+++ b/configure.in
@@ -483,7 +483,7 @@ dnl **************************************************
dnl NNTP support.
dnl **************************************************
AC_ARG_ENABLE(nntp,
-[ --enable-nntp=[no/yes] Enable NNTP support in evolution],,enable_nntp=no)
+[ --enable-nntp=[no/yes] Attempt to compile incomplete, unsupported NNTP code],,enable_nntp=no)
if test "x$enable_nntp" = "xyes"; then
AC_DEFINE(ENABLE_NNTP)
msg_nntp=yes
@@ -772,6 +772,7 @@ dnl needed by Camel (SSL and S/MIME).
dnl
dnl The Evolution security extensions are only built if these libraries are found
dnl ********************************************************************************
+msg_ssl=no
AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozilla nspr4 includes.],
with_nspr_includes="$withval", with_nspr_includes="/usr/include/nspr")
have_nspr_includes="no"
@@ -861,7 +862,6 @@ fi
AC_ARG_WITH(nss-libs, [ --with-nss-libs=PREFIX Location of Mozilla nss3 libs.],
with_nss_libs="$withval")
-msg_nss="no"
if test "x${with_nss_libs}" != "xno" -a "x${have_nss_includes}" != "xno"; then
LDFLAGS_save="$LDFLAGS"
@@ -875,7 +875,8 @@ if test "x${with_nss_libs}" != "xno" -a "x${have_nss_includes}" != "xno"; then
])
if test "$moz_nss_libs" != no; then
AC_DEFINE(HAVE_NSS)
- msg_nss="yes"
+ AC_DEFINE(HAVE_SSL)
+ msg_ssl="yes (Mozilla NSS)"
NSS_LDFLAGS="-L$with_nss_libs $nsslibs"
else
NSS_CFLAGS=""
@@ -896,7 +897,7 @@ dnl ******************************
dnl OpenSSL
dnl ******************************
-if test "x${msg_nss}" != "xyes"; then
+if test "$msg_ssl" = "no"; then
AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
with_openssl_includes="$withval", with_openssl_includes="/usr/include")
have_openssl_includes="no"
@@ -923,7 +924,6 @@ if test "x${msg_nss}" != "xyes"; then
AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
with_openssl_libs="$withval")
- msg_openssl="no"
if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
LDFLAGS_save="$LDFLAGS"
@@ -941,7 +941,8 @@ if test "x${msg_nss}" != "xyes"; then
])
if test "x${openssl_libs}" != "xno"; then
AC_DEFINE(HAVE_OPENSSL)
- msg_openssl="yes"
+ AC_DEFINE(HAVE_SSL)
+ msg_ssl="yes (OpenSSL)"
OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
else
OPENSSL_CFLAGS=""
@@ -954,23 +955,11 @@ if test "x${msg_nss}" != "xyes"; then
else
OPENSSL_CFLAGS=""
OPENSSL_LDFLAGS=""
- msg_openssl="no"
fi
AC_SUBST(OPENSSL_CFLAGS)
AC_SUBST(OPENSSL_LDFLAGS)
-dnl ******************************
-dnl See if we have SSL support
-dnl ******************************
-
-if test "x${msg_nss}" != "xno" -o "x${msg_openssl}" != "xno"; then
- msg_ssl="yes"
- AC_DEFINE(HAVE_SSL)
-else
- msg_ssl="no"
-fi
-
##################################################
# Check for gtk-doc.
##################################################
@@ -1156,13 +1145,15 @@ fi
echo "
Mail Directory: $system_mail_dir, $system_mail_perm
- LDAP support: $msg_ldap $msg_ldap_linktype
- NNTP support: $msg_nntp
+ LDAP support: $msg_ldap $msg_ldap_linktype"
+if test "$msg_nntp" = "yes"; then
+echo "\
+ NNTP support: $msg_nntp"
+fi
+echo "\
Pilot conduits: $msg_pilot
Kerberos 4/5: $msg_krb4/$msg_krb5
SSL support: $msg_ssl
- S/MIME support: $msg_nss
- Use movemail: $with_movemail
Dot Locking: $msg_dot
File Locking: $msg_file
Gtk-doc: $enable_gtk_doc"