aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2003-10-25 05:57:11 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2003-10-25 05:57:11 +0800
commitb884a6479092f8e67285c8dd959e49ecd330ce04 (patch)
treecee3ba1b8222430dd9fca6775c299821411c8bf5 /configure.in
parent10c4c2efcf77356b28c8ef249a176e30f8b19ace (diff)
downloadgsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar.gz
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar.bz2
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar.lz
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar.xz
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.tar.zst
gsoc2013-evolution-b884a6479092f8e67285c8dd959e49ecd330ce04.zip
added a configure check for AI_ADDRCONFIG
2003-10-17 Jeffrey Stedfast <fejj@ximian.com> * configure.in: added a configure check for AI_ADDRCONFIG svn path=/trunk/; revision=23076
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 07d94194d5..36fc58990b 100644
--- a/configure.in
+++ b/configure.in
@@ -295,6 +295,20 @@ fi
if test "x$enable_ipv6" = "xyes"; then
AC_DEFINE(ENABLE_IPv6,1,[Enable IPv6 support])
+ AC_TRY_COMPILE([
+ #include "confdefs.h"
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+
+ ],[
+ struct addrinfo hints;
+
+ hints.ai_flags = AI_ADDRCONFIG;
+ ],[
+ AC_DEFINE(HAVE_AI_ADDRCONFIG,1,[Define if the system defines the AI_ADDRCONFIG flag for getaddrinfo])
+ ])
fi
AM_CONDITIONAL(ENABLE_IPv6, test "x$enable_ipv6" = "xyes")
@@ -395,7 +409,7 @@ AC_SUBST(DB3_LDADD)
AC_CACHE_CHECK([that db3 library version matches header version], ac_cv_db3_lib_version_match,
[
- LIBS="$DB3_LDADD $LIBS"
+ LIBS="$DB3_LDADD $LIBS -pthread"
AC_TRY_RUN([
#ifdef HAVE_DB3_DB_H
#include <db3/db.h>