aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@src.gnome.org>2000-05-02 01:48:01 +0800
committerAnders Carlsson <andersca@src.gnome.org>2000-05-02 01:48:01 +0800
commit0b889518d2fdfd0e296179bf581c7fbff4e5210e (patch)
tree52feaf6204c272d495d667c714340674a0af8b74 /configure.in
parent88c3bbaecb41153aa9e00bff25962487db4ba8fe (diff)
downloadgsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar.gz
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar.bz2
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar.lz
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar.xz
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.tar.zst
gsoc2013-evolution-0b889518d2fdfd0e296179bf581c7fbff4e5210e.zip
Automatic check for oaf. Thanks ettore, you rule!
svn path=/trunk/; revision=2715
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a72648dd7c..2967320752 100644
--- a/configure.in
+++ b/configure.in
@@ -327,8 +327,14 @@ dnl ******************************
dnl Whether to use OAF
dnl ******************************
-AC_ARG_ENABLE(oaf,
- [ --enable-oaf=[no/yes] Use OAF instead of GOAD.],,enable_oaf=no)
+AC_MSG_CHECKING(if Bonobo uses OAF)
+if ( gnome-config --libs bonobo | grep oaf ) > /dev/null 2>&1 ; then
+ enable_oaf="yes"
+else
+ enable_oaf="no"
+fi
+
+AC_MSG_RESULT("$enable_oaf")
if test "x$enable_oaf" = "xyes"; then
AC_PATH_PROG(OAF_CONFIG,oaf-config,no)