aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-04-16 23:52:49 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-04-16 23:52:49 +0800
commitd0df7bb2932cb4304fdc4476786f252672799ee1 (patch)
treec611454d30fa9a98f59f6d6b1db220c6c87db43e /configure.in
parent99e9e1ab55442689a3a5fd188c4dbc1460a58829 (diff)
downloadgsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar.gz
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar.bz2
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar.lz
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar.xz
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.tar.zst
gsoc2013-evolution-d0df7bb2932cb4304fdc4476786f252672799ee1.zip
Pull up fix from the branch:
Check for Editor.idl in the GNOME_PATH as well. Add `doc' to the SUBDIRS in the top-level Makefile. svn path=/trunk/; revision=9376
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 26665c9231..ae6910c3aa 100644
--- a/configure.in
+++ b/configure.in
@@ -369,14 +369,30 @@ fi
AC_MSG_CHECKING(for Editor.idl in `gnome-config --datadir`/gtkhtml or ${html_prefix}/share/gtkhtml)
if test -f `gnome-config --datadir`/gtkhtml/Editor.idl; then
GTK_HTML_EDITOR_IDL=`gnome-config --datadir`/gtkhtml/Editor.idl
- AC_MSG_RESULT(found)
+ AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
else
if test -f ${html_prefix}/share/gtkhtml/Editor.idl; then
GTK_HTML_EDITOR_IDL=${html_prefix}/share/gtkhtml/Editor.idl
- AC_MSG_RESULT(found)
+ AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
else
- AC_MSG_ERROR(Editor.idl is required to compile Evolution composer, it's included in GtkHTML
-You need GtkHTML build with html-editor-control)
+ AC_MSG_RESULT(not found)
+ if test "x$GNOME_PATH" != "x" ; then
+ for dir in `echo $GNOME_PATH | sed -e "s/:/ /" `; do
+ AC_MSG_CHECKING(for Editor.idl in ${dir})
+ if test -f ${dir}/share/gtkhtml/Editor.idl ; then
+ GTK_HTML_EDITOR_IDL=${dir}/share/gtkhtml/Editor.idl
+ AC_MSG_RESULT(found - $GTK_HTML_EDITOR_IDL)
+ break
+ else
+ AC_MSG_RESULT(not found)
+ fi
+ done
+ fi
+
+ if test "x$GTK_HTML_EDITOR_IDL" = "x" ; then
+ AC_MSG_ERROR(Editor.idl is required to compile Evolution; it's included in GtkHTML.
+You need GtkHTML built with html-editor-control)
+ fi
fi
fi